Symfony's incorrect parsing of PATH_INFO can lead to limited authorization bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Symfony's HttpFoundation component defines an object-oriented layer for the HTTP specification. Starting in version 2.0.0 and prior to version 5.4.50, 6.4.29, and 7.3.7, the `Request` class improperly interprets some `PATH_INFO` in a way that leads to representing some URLs with a path that doesn't start with a `/`. This can allow bypassing some access control rules that are built with this `/`-prefix assumption. Starting in versions 5.4.50, 6.4.29, and 7.3.7, the `Request` class now ensures that URL paths always start with a `/`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 | 5.4.50, 6.4.29, 7.3.7 | Patch available | CNA |
| — | symfony/http-foundation (Packagist) | before 5.4.50 | 5.4.50 | Patch available | GHSA-3rg7-wf37-54rm |
| — | symfony/http-foundation (Packagist) | 6.0.0 to before 6.4.29 | 6.4.29 | Patch available | GHSA-3rg7-wf37-54rm |
| — | symfony/http-foundation (Packagist) | 7.0.0 to before 7.3.7 | 7.3.7 | Patch available | GHSA-3rg7-wf37-54rm |
| — | symfony/symfony (Packagist) | 2.0.0 to before 5.4.50 | 5.4.50 | Patch available | GHSA-3rg7-wf37-54rm |
| — | symfony/symfony (Packagist) | 6.0.0 to before 6.4.29 | 6.4.29 | Patch available | GHSA-3rg7-wf37-54rm |
| — | symfony/symfony (Packagist) | 7.0.0 to before 7.3.7 | 7.3.7 | Patch available | GHSA-3rg7-wf37-54rm |
- symfony Vendorsymfony Affected 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 Fixed in 5.4.50, 6.4.29, 7.3.7 Patch available CNA
- symfony/http-foundation (Packagist) Vendor— Affected before 5.4.50 Fixed in 5.4.50 Patch available GHSA-3rg7-wf37-54rm
- symfony/http-foundation (Packagist) Vendor— Affected 6.0.0 to before 6.4.29 Fixed in 6.4.29 Patch available GHSA-3rg7-wf37-54rm
- symfony/http-foundation (Packagist) Vendor— Affected 7.0.0 to before 7.3.7 Fixed in 7.3.7 Patch available GHSA-3rg7-wf37-54rm
- symfony/symfony (Packagist) Vendor— Affected 2.0.0 to before 5.4.50 Fixed in 5.4.50 Patch available GHSA-3rg7-wf37-54rm
- symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.4.29 Fixed in 6.4.29 Patch available GHSA-3rg7-wf37-54rm
- symfony/symfony (Packagist) Vendor— Affected 7.0.0 to before 7.3.7 Fixed in 7.3.7 Patch available GHSA-3rg7-wf37-54rm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:httpfoundation:*:*:*:*:*:*:*:* | 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:httpfoundation:*:*:*:*:*:*:*:* Versions 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.0.0 to before 5.4.50; 6.0.0 to before 6.4.29; 7.0.0 to before 7.3.7 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 5.4.50, 6.4.29, 7.3.7
- Fix · GHSA-3rg7-wf37-54rm symfony/http-foundation (Packagist) Fixed in 5.4.50 Advisory →
- Fix · GHSA-3rg7-wf37-54rm symfony/http-foundation (Packagist) Fixed in 6.4.29 Advisory →
- Fix · GHSA-3rg7-wf37-54rm symfony/http-foundation (Packagist) Fixed in 7.3.7 Advisory →
- Fix · GHSA-3rg7-wf37-54rm symfony/symfony (Packagist) Fixed in 5.4.50 Advisory →
- Fix · GHSA-3rg7-wf37-54rm symfony/symfony (Packagist) Fixed in 6.4.29 Advisory →
- Fix · GHSA-3rg7-wf37-54rm symfony/symfony (Packagist) Fixed in 7.3.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-64500
- 2026-10-03 Alias added: GHSA-3rg7-wf37-54rm
References
Advisory 5
- https://github.com/symfony/symfony/security/advisories/GHSA-3rg7-wf37-54rm
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2025-64500.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2025-64500.yaml
- https://symfony.com/blog/cve-2025-64500-incorrect-parsing-of-path-info-can-lead-to-limited-authorization-bypass
- https://nvd.nist.gov/vuln/detail/CVE-2025-64500
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2025-64500 · CVE Program
- CVE-2025-64500 · NVD
- FIRST EPSS
- GHSA-3rg7-wf37-54rm · GitHub Advisory Database · CC BY 4.0
- CVE-2025-64500 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences