Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.0.0 and later; 7.0.0 and later | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 6.8.0 | 6.8.0 | Patch available | GHSA-rg58-xhh7-mqjw |
| — | org.apache.struts:struts2-core (Maven) | 7.0.0 to before 7.1.1 | 7.1.1 | Patch available | GHSA-rg58-xhh7-mqjw |
- Apache Struts VendorApache Affected 2.0.0 and later; 7.0.0 and later Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 6.8.0 Fixed in 6.8.0 Patch available GHSA-rg58-xhh7-mqjw
- org.apache.struts:struts2-core (Maven) Vendor— Affected 7.0.0 to before 7.1.1 Fixed in 7.1.1 Patch available GHSA-rg58-xhh7-mqjw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* | 2.0.0 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 to before 6.8.0; 7.0.0 to before 7.1.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 to before 6.8.0; 7.0.0 to before 7.1.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-rg58-xhh7-mqjw org.apache.struts:struts2-core (Maven) Fixed in 6.8.0 Advisory →
- Fix · GHSA-rg58-xhh7-mqjw org.apache.struts:struts2-core (Maven) Fixed in 7.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66675
- 2026-10-03 Alias added: GHSA-rg58-xhh7-mqjw
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2025-66675 · CVE Program
- CVE-2025-66675 · NVD
- FIRST EPSS
- GHSA-rg58-xhh7-mqjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences