Read the docs
TI-2025-41380 Aliases CVE-2025-67637GHSA-fxj7-6v9w-xc76

Cleartext storage of sensitive information in Jenkins

Priority LOW 19CWE-312Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-312.

Summary

Jenkins 2.540 and earlier, LTS 2.528.2 and earlier stores build authorization tokens unencrypted in job config.xml files on the Jenkins controller where they can be viewed by users with Item/Extended Read permission or access to the Jenkins controller file system.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00181 7th percentileScored 2026-11-07
Fix Partial Jenkins (Jenkins Project): 2.541, 2.528.3org.jenkins-ci.main:jenkins-core (Maven): 2.541, 2.528.3Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.541, 2.528.3Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.529 to before 2.5412.541Patch availableGHSA-fxj7-6v9w-xc76
—org.jenkins-ci.main:jenkins-core (Maven)before 2.528.32.528.3Patch availableGHSA-fxj7-6v9w-xc76
  • Jenkins VendorJenkins Affected — Fixed in 2.541, 2.528.3 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.529 to before 2.541 Fixed in 2.541 Patch available GHSA-fxj7-6v9w-xc76
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.528.3 Fixed in 2.528.3 Patch available GHSA-fxj7-6v9w-xc76

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.528.3VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.541VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.528.3 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.541 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.541, 2.528.3
  • Fix · GHSA-fxj7-6v9w-xc76 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.541 Advisory →
  • Fix · GHSA-fxj7-6v9w-xc76 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.528.3 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2025-12-10

    5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW

    Other records, highest priority first

    • TI-2025-41378 Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI…Priority MEDIUM 40
    • TI-2025-41379 Missing authorization in JenkinsPriority LOW 20
    • TI-2025-41381 Cleartext storage of sensitive information in JenkinsPriority LOW 19

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Developer Tools and ServicesAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67637
  2. 2026-10-03 Alias added: GHSA-fxj7-6v9w-xc76

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources