WordPress Membership For WooCommerce plugin <= 3.0.3 - Insecure Direct Object References (IDOR) vulnerability
Priority LOW 39CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
Authorization Bypass Through User-Controlled Key vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Membership For WooCommerce: from n/a through <= 3.0.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00389 33rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67909
- 2026-10-03 Alias added: GHSA-77hc-4gv2-jvc3
More WP Swings vulnerabilities
- TI-2022-04023 Membership For WooCommerce < 2.1.7 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2022-03713 Return Refund and Exchange For WooCommerce < 4.0.9 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2022-03957 PDF Generator for WordPress < 1.1.2 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-07810 WooCommerce Ultimate Gift Card <= 2.9.2 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2022-04044 Mautic Integration For WooCommerce < 1.0.3 - Arbitrary Options Update via CSRF CVSS 3.1MEDIUM 4.3
- TI-2025-05629 Unrestricted file upload in WP Swings WooCommerce Refund And Exchange with RMA - Warranty… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-67909 · CVE Program
- CVE-2025-67909 · NVD
- FIRST EPSS
- GHSA-77hc-4gv2-jvc3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences