Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 8.6.1; 9.0.0 to before 9.1.0-alpha.3 | 8.6.1, 9.1.0-alpha.3 | Patch available | CNA |
| — | parse-server (npm) | before 8.6.1 | 8.6.1 | Patch available | GHSA-jhgf-2h8h-ggxv |
| — | parse-server (npm) | 9.0.0 to before 9.1.0-alpha.3 | 9.1.0-alpha.3 | Patch available | GHSA-jhgf-2h8h-ggxv |
- parse-server Vendorparse-community Affected before 8.6.1; 9.0.0 to before 9.1.0-alpha.3 Fixed in 8.6.1, 9.1.0-alpha.3 Patch available CNA
- parse-server (npm) Vendor— Affected before 8.6.1 Fixed in 8.6.1 Patch available GHSA-jhgf-2h8h-ggxv
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.1.0-alpha.3 Fixed in 9.1.0-alpha.3 Patch available GHSA-jhgf-2h8h-ggxv
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:-:*:*:*:node.js:*:* | 9.0.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha1:*:*:*:node.js:*:* | 9.0.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha10:*:*:*:node.js:*:* | 9.0.0 alpha10 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha11:*:*:*:node.js:*:* | 9.0.0 alpha11 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha2:*:*:*:node.js:*:* | 9.0.0 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha3:*:*:*:node.js:*:* | 9.0.0 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha4:*:*:*:node.js:*:* | 9.0.0 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha5:*:*:*:node.js:*:* | 9.0.0 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha6:*:*:*:node.js:*:* | 9.0.0 alpha6 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:-:*:*:*:node.js:*:* Versions 9.0.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha1:*:*:*:node.js:*:* Versions 9.0.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha10:*:*:*:node.js:*:* Versions 9.0.0 alpha10 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha11:*:*:*:node.js:*:* Versions 9.0.0 alpha11 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha2:*:*:*:node.js:*:* Versions 9.0.0 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha3:*:*:*:node.js:*:* Versions 9.0.0 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha4:*:*:*:node.js:*:* Versions 9.0.0 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha5:*:*:*:node.js:*:* Versions 9.0.0 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha6:*:*:*:node.js:*:* Versions 9.0.0 alpha6 Vulnerable ·parse-community
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha7:*:*:*:node.js:*:* | 9.0.0 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha8:*:*:*:node.js:*:* | 9.0.0 alpha8 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha9:*:*:*:node.js:*:* | 9.0.0 alpha9 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha1:*:*:*:node.js:*:* | 9.1.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha2:*:*:*:node.js:*:* | 9.1.0 alpha2 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha7:*:*:*:node.js:*:* Versions 9.0.0 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha8:*:*:*:node.js:*:* Versions 9.0.0 alpha8 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha9:*:*:*:node.js:*:* Versions 9.0.0 alpha9 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha1:*:*:*:node.js:*:* Versions 9.1.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha2:*:*:*:node.js:*:* Versions 9.1.0 alpha2 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.1, 9.1.0-alpha.3
- Fix · GHSA-jhgf-2h8h-ggxv parse-server (npm) Fixed in 8.6.1 Advisory →
- Fix · GHSA-jhgf-2h8h-ggxv parse-server (npm) Fixed in 9.1.0-alpha.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68115
- 2026-10-03 Alias added: GHSA-jhgf-2h8h-ggxv
References
Patch 2
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2025-68115 · CVE Program
- CVE-2025-68115 · NVD
- FIRST EPSS
- GHSA-jhgf-2h8h-ggxv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences