Read the docs
TI-2025-41730 Aliases CVE-2025-68150GHSA-3f5f-xgrj-97pf

Parse Server has Server-Side Request Forgery (SSRF) in Instagram OAuth Adapter

Priority LOW 36CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.2 and 9.1.1-alpha.1, the Instagram authentication adapter allows clients to specify a custom API URL via the `apiURL` parameter in `authData`. This enables SSRF attacks and possibly authentication bypass if malicious endpoints return fake responses to validate unauthorized users. This is fixed in versions 8.6.2 and 9.1.1-alpha.1 by hardcoding the Instagram Graph API URL `https://graph.instagram.com` and ignoring client-provided `apiURL` values. No known workarounds are available.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 8.6.2, 9.1.1-alpha.1parse-server (npm): 9.1.1-alpha.1, 8.6.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-serverbefore 8.6.2; 9.0.0 to before 9.1.1-alpha.18.6.2, 9.1.1-alpha.1Patch availableCNA
—parse-server (npm)9.0.0 to before 9.1.1-alpha.19.1.1-alpha.1Patch availableGHSA-3f5f-xgrj-97pf
—parse-server (npm)before 8.6.28.6.2Patch availableGHSA-3f5f-xgrj-97pf
  • parse-server Vendorparse-community Affected before 8.6.2; 9.0.0 to before 9.1.1-alpha.1 Fixed in 8.6.2, 9.1.1-alpha.1 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.1.1-alpha.1 Fixed in 9.1.1-alpha.1 Patch available GHSA-3f5f-xgrj-97pf
  • parse-server (npm) Vendor— Affected before 8.6.2 Fixed in 8.6.2 Patch available GHSA-3f5f-xgrj-97pf

CPE configurations NVD · 18

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 8.6.2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:-:*:*:*:node.js:*:*9.0.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha1:*:*:*:node.js:*:*9.0.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha10:*:*:*:node.js:*:*9.0.0 alpha10Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha11:*:*:*:node.js:*:*9.0.0 alpha11Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha2:*:*:*:node.js:*:*9.0.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha3:*:*:*:node.js:*:*9.0.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha4:*:*:*:node.js:*:*9.0.0 alpha4Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha5:*:*:*:node.js:*:*9.0.0 alpha5Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha6:*:*:*:node.js:*:*9.0.0 alpha6Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:-:*:*:*:node.js:*:* Versions 9.0.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha1:*:*:*:node.js:*:* Versions 9.0.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha10:*:*:*:node.js:*:* Versions 9.0.0 alpha10 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha11:*:*:*:node.js:*:* Versions 9.0.0 alpha11 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha2:*:*:*:node.js:*:* Versions 9.0.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha3:*:*:*:node.js:*:* Versions 9.0.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha4:*:*:*:node.js:*:* Versions 9.0.0 alpha4 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha5:*:*:*:node.js:*:* Versions 9.0.0 alpha5 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha6:*:*:*:node.js:*:* Versions 9.0.0 alpha6 Vulnerable ·parse-community
Show 8 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha7:*:*:*:node.js:*:*9.0.0 alpha7Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha8:*:*:*:node.js:*:*9.0.0 alpha8Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha9:*:*:*:node.js:*:*9.0.0 alpha9Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.1.0:-:*:*:*:node.js:*:*9.1.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha1:*:*:*:node.js:*:*9.1.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha2:*:*:*:node.js:*:*9.1.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha3:*:*:*:node.js:*:*9.1.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha4:*:*:*:node.js:*:*9.1.0 alpha4Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha7:*:*:*:node.js:*:* Versions 9.0.0 alpha7 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha8:*:*:*:node.js:*:* Versions 9.0.0 alpha8 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.0.0:alpha9:*:*:*:node.js:*:* Versions 9.0.0 alpha9 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.1.0:-:*:*:*:node.js:*:* Versions 9.1.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha1:*:*:*:node.js:*:* Versions 9.1.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha2:*:*:*:node.js:*:* Versions 9.1.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha3:*:*:*:node.js:*:* Versions 9.1.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.1.0:alpha4:*:*:*:node.js:*:* Versions 9.1.0 alpha4 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 8.6.2, 9.1.1-alpha.1
  • Fix · GHSA-3f5f-xgrj-97pf parse-server (npm) Fixed in 9.1.1-alpha.1 Advisory →
  • Fix · GHSA-3f5f-xgrj-97pf parse-server (npm) Fixed in 8.6.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68150
  2. 2026-10-03 Alias added: GHSA-3f5f-xgrj-97pf

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources