Elasticsearch Allocation of Resources Without Limits or Throttling
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
Allocation of Resources Without Limits or Throttling (CWE-770) in Elasticsearch can allow a low-privileged authenticated user to cause Excessive Allocation (CAPEC-130) causing a persistent denial of service (OOM crash) via submission of oversized user settings data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 7.0.0 – 7.17.29; 8.0.0 – 8.19.8; 9.0.0 – 9.1.8; 9.2.0 – 9.2.2 | — | No fix listed | CNA |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | before 8.19.9 | 8.19.9 | Patch available | GHSA-qf7c-7r9h-mm92 |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | 9.0.0 to before 9.1.9 | 9.1.9 | Patch available | GHSA-qf7c-7r9h-mm92 |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | 9.2.0 to before 9.2.3 | 9.2.3 | Patch available | GHSA-qf7c-7r9h-mm92 |
- Elasticsearch VendorElastic Affected 7.0.0 – 7.17.29; 8.0.0 – 8.19.8; 9.0.0 – 9.1.8; 9.2.0 – 9.2.2 Fixed in — No fix listed CNA
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected before 8.19.9 Fixed in 8.19.9 Patch available GHSA-qf7c-7r9h-mm92
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected 9.0.0 to before 9.1.9 Fixed in 9.1.9 Patch available GHSA-qf7c-7r9h-mm92
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected 9.2.0 to before 9.2.3 Fixed in 9.2.3 Patch available GHSA-qf7c-7r9h-mm92
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* | 7.0.0 – 7.17.29; 8.0.0 to before 8.19.9; 9.0.0 to before 9.1.9; 9.2.0 to before 9.2.3 | Vulnerable | Elastic |
- cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions 7.0.0 – 7.17.29; 8.0.0 to before 8.19.9; 9.0.0 to before 9.1.9; 9.2.0 to before 9.2.3 Vulnerable ·Elastic
Remediation
- Fix · GHSA-qf7c-7r9h-mm92 org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 8.19.9 Advisory →
- Fix · GHSA-qf7c-7r9h-mm92 org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 9.1.9 Advisory →
- Fix · GHSA-qf7c-7r9h-mm92 org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 9.2.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68384
- 2026-10-03 Alias added: GHSA-qf7c-7r9h-mm92
References
Advisory 2
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-68384 · CVE Program
- CVE-2025-68384 · NVD
- FIRST EPSS
- GHSA-qf7c-7r9h-mm92 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-68384 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences