Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component
Priority HIGH 66CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.50424 98th percentileScored 2026-11-07
Fix Partial Apache Struts (Apache Software Foundation): 2.2.1org.apache.struts:struts2-core (Maven): 6.1.1Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.0.0 to before 2.2.1 | 2.2.1 | Patch available | CNA |
| Apache | Apache Struts | 2.2.1 – 6.1.0 | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 – 2.3.37 | — | No fix listed | GHSA-qcfc-hmrc-59x7 |
| — | org.apache.struts:struts2-core (Maven) | 2.5.0 – 2.5.33 | — | No fix listed | GHSA-qcfc-hmrc-59x7 |
| — | org.apache.struts:struts2-core (Maven) | 6.0.0 to before 6.1.1 | 6.1.1 | Patch available | GHSA-qcfc-hmrc-59x7 |
| — | com.opensymphony:xwork (Maven) | 2.0.0 and later | — | No fix listed | GHSA-qcfc-hmrc-59x7 |
| — | org.apache.struts.xwork:xwork-core (Maven) | 2.2.1 and later | — | No fix listed | GHSA-qcfc-hmrc-59x7 |
- Apache Struts VendorApache Affected 2.0.0 to before 2.2.1 Fixed in 2.2.1 Patch available CNA
- Apache Struts VendorApache Affected 2.2.1 – 6.1.0 Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 – 2.3.37 Fixed in — No fix listed GHSA-qcfc-hmrc-59x7
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.5.0 – 2.5.33 Fixed in — No fix listed GHSA-qcfc-hmrc-59x7
- org.apache.struts:struts2-core (Maven) Vendor— Affected 6.0.0 to before 6.1.1 Fixed in 6.1.1 Patch available GHSA-qcfc-hmrc-59x7
- com.opensymphony:xwork (Maven) Vendor— Affected 2.0.0 and later Fixed in — No fix listed GHSA-qcfc-hmrc-59x7
- org.apache.struts.xwork:xwork-core (Maven) Vendor— Affected 2.2.1 and later Fixed in — No fix listed GHSA-qcfc-hmrc-59x7
Remediation
- Fix · CNA Apache Struts (Apache Software Foundation) Fixed in 2.2.1
- Fix · GHSA-qcfc-hmrc-59x7 org.apache.struts:struts2-core (Maven) Fixed in 6.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Red Hat Enterprise Linux 8
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68493
- 2026-10-03 Alias added: GHSA-qcfc-hmrc-59x7
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2025-68493 · CVE Program
- CVE-2025-68493 · NVD
- FIRST EPSS
- GHSA-qcfc-hmrc-59x7 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-68493 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences