Read the docs
TI-2025-42152 Aliases CVE-2025-68658

Open Source Point of Sale (opensourcepos) Stored XSS in Configuration (Information) – Company Name field

Priority LOW 21CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. opensourcepos 3.4.0 and 3.4.1 has a stored XSS vulnerability exists in the Configuration (Information) functionality. An authenticated user with the permission “Configuration: Change OSPOS's Configuration” can inject a malicious JavaScript payload into the Company Name field when updating Information in Configuration. The malicious payload is stored and later triggered when a user accesses /sales/complete. First select Sales, and choose New Item to create an item, then click on Completed . Due to insufficient input validation and output encoding, the payload is rendered and executed in the user’s browser, resulting in a stored XSS vulnerability. This vulnerability is fixed in 3.4.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00219 12th percentileScored 2026-11-07
Fix Fixed opensourcepos (opensourcepos): 3.4.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opensourceposopensourceposbefore 3.4.23.4.2Patch availableCNA
  • opensourcepos Vendoropensourcepos Affected before 3.4.2 Fixed in 3.4.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:*3.4.0 to before 3.4.2Vulnerableopensourcepos
  • cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:* Versions 3.4.0 to before 3.4.2 Vulnerable ·opensourcepos

Remediation

  • Fix · CNA opensourcepos (opensourcepos) Fixed in 3.4.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68658

References

  • TI-2026-25347 Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality CVSS 3.1HIGH 8.8
  • TI-2025-41982 opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation CVSS 3.1HIGH 8.8
  • TI-2025-41728 opensourcepos has a Cross-site Scripting vulnerability CVSS 3.1HIGH 8.1
  • TI-2025-43027 An issue in OpenSourcePOS v3.4.1 allows attackers to execute arbitrary code via returning a crafted AJAX response. CVSS 3.1HIGH 7.4
  • TI-2025-41087 A Cross-site scripting (XSS) vulnerability in Create/Update Customer(s) in Open Source… CVSS 3.1HIGH 7.2
  • TI-2025-41086 A Cross-site scripting (XSS) vulnerability in Create/Update Item(s) Module in Open Source… CVSS 3.1HIGH 7.2
See all 18 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences