Cross-site scripting in ONLYOFFICE Document Server
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
ONLYOFFICE Docs before 9.2.1 allows XSS in the textarea of the comment editing form. This is related to DocumentServer.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00177 7th percentileScored 2026-11-07
Fix Fixed Document Server (ONLYOFFICE): 9.2.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ONLYOFFICE | Document Server | before 9.2.1 | 9.2.1 | Patch available | CNA |
- Document Server VendorONLYOFFICE Affected before 9.2.1 Fixed in 9.2.1 Patch available CNA
Remediation
- Fix · CNA Document Server (ONLYOFFICE) Fixed in 9.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68917
- 2026-10-03 Alias added: GHSA-9gpx-4hwh-g499
More ONLYOFFICE vulnerabilities
- TI-2021-02273 Path traversal in ONLYOFFICE Document Server enables code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2023-17445 Onlyoffice Community Server before v12.5.2 was discovered to contain a remote code… CVSS 3.1CRITICAL 9.8
- TI-2023-14162 An out of bounds memory access vulnerability in ONLYOFFICE DocumentServer 4.0.3 through… CVSS 3.1CRITICAL 9.8
- TI-2023-14161 A use after free issue discovered in ONLYOFFICE DocumentServer 4.0.3 through 7.3.2 allows… CVSS 3.1CRITICAL 9.8
- TI-2023-14163 Memory Exhaustion vulnerability in ONLYOFFICE Document Server 4.0.3 through 7.3.2 allows… CVSS 3.1HIGH 7.5
- TI-2021-19374 ONLYOFFICE all versions as of 2021-11-08 is affected by Incorrect Access Control. CVSS 3.1HIGH 7.5
Sources
- CVE-2025-68917 · CVE Program
- CVE-2025-68917 · NVD
- FIRST EPSS
- GHSA-9gpx-4hwh-g499 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences