Read the docs
TI-2025-42407 Aliases CVE-2025-68951GHSA-jv8r-hv7q-p6vc

phpMyFAQ has stored XSS in admin "List of users" via display_name HTML entity decoding (html_entity_decode) + Twig |raw

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

phpMyFAQ is an open source FAQ web application. Versions 4.0.14 and 4.0.15 have a stored cross-site scripting (XSS) vulnerability that allows an attacker to execute arbitrary JavaScript in an administrator’s browser by registering a user whose display name contains HTML entities. When an administrator views the admin user list, the payload is decoded server-side and rendered without escaping, resulting in script execution in the admin context. Version 4.0.16 contains a patch for the issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0028 20th percentileScored 2026-11-07
Fix Fixed phpMyFAQ (thorsten): 4.0.16thorsten/phpmyfaq (Packagist): 4.0.16

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
thorstenphpMyFAQ4.0.14 to before 4.0.164.0.16Patch availableCNA
—thorsten/phpmyfaq (Packagist)4.0.14 to before 4.0.164.0.16Patch availableGHSA-jv8r-hv7q-p6vc
  • phpMyFAQ Vendorthorsten Affected 4.0.14 to before 4.0.16 Fixed in 4.0.16 Patch available CNA
  • thorsten/phpmyfaq (Packagist) Vendor— Affected 4.0.14 to before 4.0.16 Fixed in 4.0.16 Patch available GHSA-jv8r-hv7q-p6vc

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*4.0.14 to before 4.0.16Vulnerablethorsten
cpe:2.3:a:phpmyfaq:phpmyfaq:4.1.0:rc:*:*:*:*:*:*4.1.0 rcVulnerablethorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:* Versions 4.0.14 to before 4.0.16 Vulnerable ·thorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:4.1.0:rc:*:*:*:*:*:* Versions 4.1.0 rc Vulnerable ·thorsten

Remediation

  • Fix · CNA phpMyFAQ (thorsten) Fixed in 4.0.16
  • Fix · GHSA-jv8r-hv7q-p6vc thorsten/phpmyfaq (Packagist) Fixed in 4.0.16 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68951
  2. 2026-10-03 Alias added: GHSA-jv8r-hv7q-p6vc

References

  • TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
  • TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
  • TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
  • TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
See all 153 →

Sources