Mattermost Zoom Plugin allows unauthorized meeting creation and post modification via insufficient API access controls
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 and Mattermost Plugin Zoom versions <=1.11.0 fail to validate user identity and post ownership in the {{/api/v1/askPMI}} endpoint which allows unauthorized users to start Zoom meetings as any user and overwrite arbitrary posts via direct API calls with manipulated user IDs and post data.. Mattermost Advisory ID: MMSA-2025-00534
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.1.0 – 11.1.2; 10.11.0 – 10.11.9; 11.2.0 – 11.2.1 | 11.3.0, 11.1.3, 10.11.10, 11.2.2 | Patch available | CNA |
| — | github.com/mattermost/mattermost-plugin-zoom (Go) | before 1.12.0 | 1.12.0 | Patch available | GHSA-w65c-fvp5-fvc5 |
- Mattermost VendorMattermost Affected 11.1.0 – 11.1.2; 10.11.0 – 10.11.9; 11.2.0 – 11.2.1 Fixed in 11.3.0, 11.1.3, 10.11.10, 11.2.2 Patch available CNA
- github.com/mattermost/mattermost-plugin-zoom (Go) Vendor— Affected before 1.12.0 Fixed in 1.12.0 Patch available GHSA-w65c-fvp5-fvc5
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.10; 11.1.0 to before 11.1.3; 11.2.0 to before 11.2.2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:zoom:*:*:*:*:*:mattermost:*:* | up to 1.11.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.10; 11.1.0 to before 11.1.3; 11.2.0 to before 11.2.2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:zoom:*:*:*:*:*:mattermost:*:* Versions up to 1.11.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.3.0, 11.1.3, 10.11.10, 11.2.2
- Fix · GHSA-w65c-fvp5-fvc5 github.com/mattermost/mattermost-plugin-zoom (Go) Fixed in 1.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-0998
- 2026-10-03 Alias added: GHSA-w65c-fvp5-fvc5
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-0998 · CVE Program
- CVE-2026-0998 · NVD
- FIRST EPSS
- GHSA-w65c-fvp5-fvc5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences