Read the docs
TI-2026-00938 Aliases CVE-2026-1217GHSA-g9w4-m5fx-x3wv

Missing authorization in Yoast Duplicate Post

Priority LOW 24CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00182 7th percentileScored 2026-11-07
Fix Fixed yoast/duplicate-post (Packagist): 4.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
YoastYoast Duplicate Postup to 4.5—No fix listedCNA
—yoast/duplicate-post (Packagist)before 4.64.6Patch availableGHSA-g9w4-m5fx-x3wv
  • Yoast Duplicate Post VendorYoast Affected up to 4.5 Fixed in — No fix listed CNA
  • yoast/duplicate-post (Packagist) Vendor— Affected before 4.6 Fixed in 4.6 Patch available GHSA-g9w4-m5fx-x3wv

Remediation

  • Fix · GHSA-g9w4-m5fx-x3wv yoast/duplicate-post (Packagist) Fixed in 4.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-1217
  2. 2026-10-03 Alias added: GHSA-g9w4-m5fx-x3wv

References

  • TI-2017-14158 Google Analytics Dashboard Plugin cross site scriting CVSS 3.1MEDIUM 6.1
  • TI-2019-15368 Duplicate-Post 3.2.3 - Persistent Cross-Site Scripting CVSS 4.0MEDIUM 4.8
  • TI-2019-10120 The Yoast SEO plugin before 11.6-RC5 for WordPress does not properly restrict unfiltered HTML in term descriptions. CVSS 3.1CRITICAL 9.8
  • TI-2023-13290 WordPress Yoast SEO: Local Plugin <= 14.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2015-02025 Multiple SQL injection vulnerabilities in admin/class-bulk-editor-list-table.php in the… CVSS 2.0MEDIUM 6.5
  • TI-2018-13725 A Race condition vulnerability in unzip_file in admin/import/class-import-settings.php in… CVSS 3.0MEDIUM 6.6
See all 27 →

Sources