Missing authorization in Metagauss EventPrime – Events Calendar, Bookings and Tickets
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The EventPrime plugin for WordPress is vulnerable to unauthorized post modification due to missing authorization checks in all versions up to, and including, 4.2.8.4. This is due to the save_frontend_event_submission function accepting a user-controlled event_id parameter and updating the corresponding event post without enforcing ownership or capability checks. This makes it possible for authenticated (Customer+) attackers to modify posts created by administrators by manipulating the event_id parameter granted they can obtain a valid nonce.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1655
- 2026-10-03 Alias added: GHSA-jh7f-pj8r-h37c
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e2a2769-1309-4aad-8411-4445efea2b66?source=cve
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-ep-ajax.php#L741
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-ep-ajax.php#L798
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/tags/4.2.8.1/includes/class-ep-ajax.php#L798
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/tags/4.2.8.1/includes/class-ep-ajax.php#L741
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3455239%40eventprime-event-calendar-management%2Ftrunk&old=3452796%40eventprime-event-calendar-management%2Ftrunk&sfp_email=&sfph_mail=
More Metagauss vulnerabilities
- TI-2023-00891 ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset CVSS 3.1HIGH 8.8
- TI-2021-07144 RegistrationMagic < 5.0.1.6 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2025-05982 Download Plugin <= 2.2.8 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2023-03938 EventPrime <= 3.2.9 - Booking Pricing Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-20215 WordPress ProfileGrid – User Profiles, Memberships, Groups and Communities plugin <= 5.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-04340 EventPrime – Events Calendar, Bookings and Tickets < 3.5.0 - Subscriber+ Arbitrary booking settings update CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-1655 · CVE Program
- CVE-2026-1655 · NVD
- FIRST EPSS
- GHSA-jh7f-pj8r-h37c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences