Reflected Cross-Site Scripting via URL Parameter in Multiple WSO2 Products Enables UI Redirection and Modification
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The affected product accepts user-supplied input within a URL parameter without enforcing expected sanitization or encoding before rendering it within the response. This condition allows for the injection of malicious JavaScript payloads. An attacker can leverage this vulnerability to cause the user's browser to redirect to a malicious website, modify the user interface of the webpage, or retrieve sensitive information from the browser. However, the impact is mitigated for session hijacking as all session-related sensitive cookies are protected by the httpOnly flag.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 4.2.0 to before 4.2.0.195; 4.3.0 to before 4.3.0.106; 4.4.0 to before 4.4.0.70; 4.5.0 to before 4.5.0.55; 4.6.0 to before 4.6.0.19 | 4.2.0.195, 4.3.0.106, 4.4.0.70, 4.5.0.55, 4.6.0.19 | Patch available | CNA |
| WSO2 | WSO2 API Control Plane | 4.5.0 to before 4.5.0.56; 4.6.0 to before 4.6.0.20 | 4.5.0.56, 4.6.0.20 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 6.0.0 to before 6.0.0.263; 6.1.0 to before 6.1.0.266; 7.0.0 to before 7.0.0.144; 7.1.0 to before 7.1.0.53; 7.2.0 to before 7.2.0.12 | 6.0.0.263, 6.1.0.266, 7.0.0.144, 7.1.0.53, 7.2.0.12 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 4.2.0 to before 4.2.0.195; 4.3.0 to before 4.3.0.106; 4.4.0 to before 4.4.0.70; 4.5.0 to before 4.5.0.55; 4.6.0 to before 4.6.0.19 Fixed in 4.2.0.195, 4.3.0.106, 4.4.0.70, 4.5.0.55, 4.6.0.19 Patch available CNA
- WSO2 API Control Plane VendorWSO2 Affected 4.5.0 to before 4.5.0.56; 4.6.0 to before 4.6.0.20 Fixed in 4.5.0.56, 4.6.0.20 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 6.0.0 to before 6.0.0.263; 6.1.0 to before 6.1.0.266; 7.0.0 to before 7.0.0.144; 7.1.0 to before 7.1.0.53; 7.2.0 to before 7.2.0.12 Fixed in 6.0.0.263, 6.1.0.266, 7.0.0.144, 7.1.0.53, 7.2.0.12 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_control_plane:*:*:*:*:*:*:*:* | 4.5.0 to before 4.5.0.56; 4.6.0 to before 4.6.0.20 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:* | 4.2.0 to before 4.2.0.195; 4.3.0 to before 4.3.0.106; 4.4.0 to before 4.4.0.70; 4.5.0 to before 4.5.0.55; 4.6.0 to before 4.6.0.19 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:* | 6.0.0 to before 6.0.0.263; 6.1.0 to before 6.1.0.266; 7.0.0 to before 7.0.0.144; 7.1.0 to before 7.1.0.53; 7.2.0 to before 7.2.0.12 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_control_plane:*:*:*:*:*:*:*:* Versions 4.5.0 to before 4.5.0.56; 4.6.0 to before 4.6.0.20 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:* Versions 4.2.0 to before 4.2.0.195; 4.3.0 to before 4.3.0.106; 4.4.0 to before 4.4.0.70; 4.5.0 to before 4.5.0.55; 4.6.0 to before 4.6.0.19 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:* Versions 6.0.0 to before 6.0.0.263; 6.1.0 to before 6.1.0.266; 7.0.0 to before 7.0.0.144; 7.1.0 to before 7.1.0.53; 7.2.0 to before 7.2.0.12 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 4.2.0.195, 4.3.0.106, 4.4.0.70, 4.5.0.55, 4.6.0.19
- Fix · CNA WSO2 API Control Plane (WSO2) Fixed in 4.5.0.56, 4.6.0.20
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 6.0.0.263, 6.1.0.266, 7.0.0.144, 7.1.0.53, 7.2.0.12
Timeline
- 2026-10-02 Threatist record created from CVE-2026-2445
- 2026-10-03 Alias added: GHSA-vcj5-r64m-jr4f
References
More WSO2 Api Control Plane vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
- TI-2025-09712 Potential Broken Access Control in Multiple WSO2 Products via System REST APIs CVSS 3.1CRITICAL 9.8
- TI-2025-08391 Improper Privilege Management in Multiple WSO2 API Manager via keymanager-operations DCR Endpoint CVSS 3.1CRITICAL 9.8
- TI-2026-01411 Privilege Escalation via System REST APIs in Multiple WSO2 Products Permits Admin Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08536 Improper Certificate-Based Authentication Enforcement in Multiple WSO2 Products CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-2445 · CVE Program
- CVE-2026-2445 · NVD
- FIRST EPSS
- GHSA-vcj5-r64m-jr4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences