Missing authorization check allows unauthorized modification of other users' comments on a board
Priority LOW 19CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
Mattermost Plugins versions <=11.3 11.0.3 11.2.2 10.10.11.0 fail to implement authorisation checks on comment block modifications, which allows an authorised attacker with editor permission to modify comments created by other board members. Mattermost Advisory ID: MMSA-2025-00559
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00169 6th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.4.0, 11.3.1, 11.2.3 +1github.com/mattermost/mattermost-plugin-boards (Go): 0.0.0-20260108044135-57c5be5b6ef5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | up to 11.0.3; up to 11.2.2; up to 10.10.11 | 11.4.0, 11.3.1, 11.2.3, 10.11.11 | Patch available | CNA |
| — | github.com/mattermost/mattermost-plugin-boards (Go) | before 0.0.0-20260108044135-57c5be5b6ef5 | 0.0.0-20260108044135-57c5be5b6ef5 | Patch available | GHSA-hf8w-x9h5-5gf9 |
- Mattermost VendorMattermost Affected up to 11.0.3; up to 11.2.2; up to 10.10.11 Fixed in 11.4.0, 11.3.1, 11.2.3, 10.11.11 Patch available CNA
- github.com/mattermost/mattermost-plugin-boards (Go) Vendor— Affected before 0.0.0-20260108044135-57c5be5b6ef5 Fixed in 0.0.0-20260108044135-57c5be5b6ef5 Patch available GHSA-hf8w-x9h5-5gf9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 10.11.11; 11.0.0 – 11.0.3; 11.1.0 to before 11.2.3; 11.3.0 to before 11.3.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 10.11.11; 11.0.0 – 11.0.3; 11.1.0 to before 11.2.3; 11.3.0 to before 11.3.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.4.0, 11.3.1, 11.2.3, 10.11.11
- Fix · GHSA-hf8w-x9h5-5gf9 github.com/mattermost/mattermost-plugin-boards (Go) Fixed in 0.0.0-20260108044135-57c5be5b6ef5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-2461
- 2026-10-03 Alias added: GHSA-hf8w-x9h5-5gf9
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-2461 · CVE Program
- CVE-2026-2461 · NVD
- FIRST EPSS
- GHSA-hf8w-x9h5-5gf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences