Read the docs
TI-2026-02314 Aliases CVE-2026-2704GHSA-6xw4-2g22-26h8

Open Babel CIF File transform3d.cpp DescribeAsString out-of-bounds

Priority LOW 26CWE-119Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

A security vulnerability has been detected in Open Babel up to 3.1.1. The affected element is the function OpenBabel::transform3d::DescribeAsString of the file src/math/transform3d.cpp of the component CIF File Handler. The manipulation leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 3.2.0 is sufficient to fix this issue. The identifier of the patch is e23a224b8fd9d7c2a7cde9ef4ec6afb4c05aa08a. It is suggested to install a patch to address this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00884 59th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed Open Babel: 3.2.0openbabel (PyPI): 3.2.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Open Babel3.1.0; 3.1.13.2.0Patch availableCNA
—openbabel (PyPI)before 3.2.03.2.0Patch availableGHSA-6xw4-2g22-26h8
  • Open Babel Vendor— Affected 3.1.0; 3.1.1 Fixed in 3.2.0 Patch available CNA
  • openbabel (PyPI) Vendor— Affected before 3.2.0 Fixed in 3.2.0 Patch available GHSA-6xw4-2g22-26h8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openbabel:open_babel:*:*:*:*:*:*:*:*up to 3.1.1VulnerableOpen Babel
  • cpe:2.3:a:openbabel:open_babel:*:*:*:*:*:*:*:* Versions up to 3.1.1 Vulnerable ·Open Babel

Remediation

  • Fix · CNA Open Babel Fixed in 3.2.0
  • Fix · GHSA-6xw4-2g22-26h8 openbabel (PyPI) Fixed in 3.2.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-2704
  2. 2026-10-03 Alias added: GHSA-6xw4-2g22-26h8

References

  • TI-2022-22844 Memory corruption in Open Babel CVSS 3.1CRITICAL 9.8
  • TI-2022-22843 Memory corruption in Open Babel CVSS 3.1CRITICAL 9.8
  • TI-2022-22840 Memory corruption in Open Babel CVSS 3.1CRITICAL 9.8
  • TI-2022-22839 Heap-based buffer overflow in Open Babel CVSS 3.1CRITICAL 9.8
  • TI-2022-22838 Heap-based buffer overflow in Open Babel CVSS 3.1CRITICAL 9.8
  • TI-2022-21850 A use of uninitialized pointer vulnerability exists in the MSI format atom functionality… CVSS 3.1CRITICAL 9.8
See all 23 →

Sources