Incorrect Authorization in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to perform unauthorized actions on merge requests in other projects due to improper access control during cross-repository operations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 11.10 to before 18.8.7; 18.9 to before 18.9.3; 18.10 to before 18.10.1 | 18.8.7, 18.9.3, 18.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 11.10 to before 18.8.7; 18.9 to before 18.9.3; 18.10 to before 18.10.1 Fixed in 18.8.7, 18.9.3, 18.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 11.10.0 to before 18.8.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 11.10.0 to before 18.8.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.9.0 to before 18.9.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.9.0 to before 18.9.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:community:*:*:* | 18.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:enterprise:*:*:* | 18.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 11.10.0 to before 18.8.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 11.10.0 to before 18.8.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.9.0 to before 18.9.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.9.0 to before 18.9.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:community:*:*:* Versions 18.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:enterprise:*:*:* Versions 18.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.8.7, 18.9.3, 18.10.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.10.1, 18.8.7, 18.9.3
11 records Highest priority Priority MEDIUM 1 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2025-11962 Improper Validation of Specified Quantity in Input in GitLabPriority MEDIUM 62
- TI-2026-03452 Inefficient Algorithmic Complexity in GitLabPriority LOW 39
- TI-2026-03343 Cross-Site Request Forgery (CSRF) in GitLabPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2026-2726
- 2026-10-03 Alias added: GHSA-4j77-rj27-2wxq
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-2726 · CVE Program
- CVE-2026-2726 · NVD
- FIRST EPSS
- GHSA-4j77-rj27-2wxq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences