Guest users can view group member IDs without respecting view restrictions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to apply view restrictions when retrieving group member IDs, which allows authenticated guest users to enumerate user IDs outside their allowed visibility scope via the group retrieval endpoint.. Mattermost Advisory ID: MMSA-2026-00594
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.2.0 – 11.2.2; 10.11.0 – 10.11.10; 11.4.0 – 11.4.0; 11.3.0 – 11.3.1 | 11.5.0, 11.2.3, 10.11.11, 11.4.1, 11.3.2 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 11.4.0 to before 11.4.1 | 11.4.1 | Patch available | GHSA-mpc7-mm28-f6wq |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 11.3.0-rc1 to before 11.3.2 | 11.3.2 | Patch available | GHSA-mpc7-mm28-f6wq |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 11.2.0-rc1 to before 11.2.3 | 11.2.3 | Patch available | GHSA-mpc7-mm28-f6wq |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.11.0-rc1 to before 10.11.11 | 10.11.11 | Patch available | GHSA-mpc7-mm28-f6wq |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 8.0.0-20260105080200-d27a2195068d to before 8.0.0-20260217110922-b7d4a1f1f59b | 8.0.0-20260217110922-b7d4a1f1f59b | Patch available | GHSA-mpc7-mm28-f6wq |
- Mattermost VendorMattermost Affected 11.2.0 – 11.2.2; 10.11.0 – 10.11.10; 11.4.0 – 11.4.0; 11.3.0 – 11.3.1 Fixed in 11.5.0, 11.2.3, 10.11.11, 11.4.1, 11.3.2 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.4.0 to before 11.4.1 Fixed in 11.4.1 Patch available GHSA-mpc7-mm28-f6wq
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.3.0-rc1 to before 11.3.2 Fixed in 11.3.2 Patch available GHSA-mpc7-mm28-f6wq
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.2.0-rc1 to before 11.2.3 Fixed in 11.2.3 Patch available GHSA-mpc7-mm28-f6wq
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.11.0-rc1 to before 10.11.11 Fixed in 10.11.11 Patch available GHSA-mpc7-mm28-f6wq
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 8.0.0-20260105080200-d27a2195068d to before 8.0.0-20260217110922-b7d4a1f1f59b Fixed in 8.0.0-20260217110922-b7d4a1f1f59b Patch available GHSA-mpc7-mm28-f6wq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.11; 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:11.4.0:*:*:*:*:*:*:* | 11.4.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.11; 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:11.4.0:*:*:*:*:*:*:* Versions 11.4.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.5.0, 11.2.3, 10.11.11, 11.4.1, 11.3.2
- Fix · GHSA-mpc7-mm28-f6wq github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.4.1 Advisory →
- Fix · GHSA-mpc7-mm28-f6wq github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.3.2 Advisory →
- Fix · GHSA-mpc7-mm28-f6wq github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.2.3 Advisory →
- Fix · GHSA-mpc7-mm28-f6wq github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.11.11 Advisory →
- Fix · GHSA-mpc7-mm28-f6wq github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260217110922-b7d4a1f1f59b Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3115
- 2026-10-03 Alias added: GHSA-mpc7-mm28-f6wq
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-3115 · CVE Program
- CVE-2026-3115 · NVD
- FIRST EPSS
- GHSA-mpc7-mm28-f6wq · GitHub Advisory Database · CC BY 4.0
- CVE-2026-3115 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences