FormGent <= 1.9.2- Missing Authorization to Unauthenticated Arbitrary File Deletion via 'file_token' Parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The FormGent plugin for WordPress is vulnerable to unauthorized arbitrary file deletion due to a missing capability check on the /wp-json/formgent/responses/attachments REST API endpoint in all versions up to, and including, 1.9.2 This is due to the REST API route being registered without any authentication middleware in routes/rest/api.php. This makes it possible for unauthenticated attackers to delete arbitrary files within the formgent uploads directory. Additionally, on Linux servers where the wp-content/uploads/formgent directory does not yet exist (the default state after plugin installation), the path traversal protection can be bypassed, enabling deletion of arbitrary files including wp-config.php which can lead to complete site takeover via a fresh WordPress installation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpWax | FormGent – Next-Gen AI Form Builder for WordPress with Multi-Step, Quizzes, Payments & More | up to 1.9.2 | — | No fix listed | CNA |
- FormGent – Next-Gen AI Form Builder for WordPress with Multi-Step, Quizzes, Payments & More VendorwpWax Affected up to 1.9.2 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3141
- 2026-10-03 Alias added: GHSA-68f5-7j6g-q5r2
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/097a9d0f-fa38-4fdc-9048-43dd65e7652c?source=cve
- https://plugins.trac.wordpress.org/browser/formgent/tags/1.3.1/app/Http/Controllers/AttachmentController.php#L59
- https://plugins.trac.wordpress.org/browser/formgent/trunk/app/Http/Controllers/AttachmentController.php#L59
- https://plugins.trac.wordpress.org/browser/formgent/tags/1.3.1/routes/rest/api.php#L27
- https://plugins.trac.wordpress.org/browser/formgent/trunk/routes/rest/api.php#L27
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fformgent/tags/1.9.2&new_path=%2Fformgent/tags/1.10.0
- https://plugins.trac.wordpress.org/changeset/3604540/formgent/trunk/app/Http/Controllers/AttachmentController.php
More wpWax vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2026-42481 WordPress Directorist plugin <= 8.8.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-23723 WordPress HelpGent plugin <= 2.2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01866 Deserialization of untrusted data in wpWax Post Grid, Slider & Carousel Ultimate – with… CVSS 3.1HIGH 8.8
- TI-2023-02111 Directorist < 7.5.4 - Admin+ LFI CVSS 3.1LOW 2.7
Sources
- CVE-2026-3141 · CVE Program
- CVE-2026-3141 · NVD
- FIRST EPSS
- GHSA-68f5-7j6g-q5r2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences