Read the docs
TI-2026-02801 Aliases CVE-2026-3240GHSA-45fj-fvmm-xcc5

Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy form

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In Concrete CMS below version 9.4.8, a user with permission to edit a page with element Legacy form can perform a stored XSS attack towards high-privilege accounts via the Question field. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Thanks minhnn42, namdi and quanlna2 from VCSLab-Viettel Cyber Security for reporting.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00242 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed concrete5/concrete5 (Packagist): 9.4.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—concrete5/concrete5 (Packagist)before 9.4.89.4.8Patch availableGHSA-45fj-fvmm-xcc5
  • concrete5/concrete5 (Packagist) Vendor— Affected before 9.4.8 Fixed in 9.4.8 Patch available GHSA-45fj-fvmm-xcc5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:*before 9.4.8VulnerableConcrete CMS
  • cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 9.4.8 Vulnerable ·Concrete CMS

Remediation

  • Fix · GHSA-45fj-fvmm-xcc5 concrete5/concrete5 (Packagist) Fixed in 9.4.8 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Concrete CMS 9.4.8

    6 records Highest priority Priority MEDIUM 1 MEDIUM, 5 LOW

    Other records, highest priority first

    • TI-2026-02973 Concrete CMS below 9.4.8 is vulnerable to stored deserialization leading to RCE in the Express Entry List block.Priority MEDIUM 42
    • TI-2026-02803 Concrete CMS below 9.4.8 is vulnerable to Stored XSS in the Switch Language blockPriority LOW 22
    • TI-2026-02802 Concrete CMS below version 9.4.8 is vulnerable to a stored cross-site scripting (XSS) in the "Legacy Form" block.Priority LOW 22

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3240
  2. 2026-10-03 Alias added: GHSA-45fj-fvmm-xcc5

References

  • TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
  • TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
  • TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
  • TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
  • TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
  • TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
See all 197 →

Sources