Concrete CMS below 9.4.8 is vulnerable to stored deserialization leading to RCE in the Express Entry List block.
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Concrete CMS below version 9.4.8 is vulnerable to Remote Code Execution by stored PHP object injection into the Express Entry List block via the columns parameter. An authenticated administrator can store attacker-controlled serialized data in block configuration fields that are later passed to unserialize() without class restrictions or integrity checks. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 8.9 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H. Thanks YJK ( @YJK0805 https://hackerone.com/yjk0805 ) of ZUSO ART https://zuso.ai/ for reporting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concrete5/concrete5 (Packagist) | before 9.4.8 | 9.4.8 | Patch available | GHSA-gj26-w59c-29mf |
- concrete5/concrete5 (Packagist) Vendor— Affected before 9.4.8 Fixed in 9.4.8 Patch available GHSA-gj26-w59c-29mf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 9.4.8 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 9.4.8 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-gj26-w59c-29mf concrete5/concrete5 (Packagist) Fixed in 9.4.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Concrete CMS 9.4.8
6 records Highest priority Priority MEDIUM 1 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2026-02803 Concrete CMS below 9.4.8 is vulnerable to Stored XSS in the Switch Language blockPriority LOW 22
- TI-2026-02802 Concrete CMS below version 9.4.8 is vulnerable to a stored cross-site scripting (XSS) in the "Legacy Form" block.Priority LOW 22
- TI-2026-02801 Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy formPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3452
- 2026-10-03 Alias added: GHSA-gj26-w59c-29mf
- 2026-10-25 EPSS moved to the below the 50th percentile
- 2026-10-29 EPSS moved to the 50th–90th percentile
References
Patch 1
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-3452 · CVE Program
- CVE-2026-3452 · NVD
- FIRST EPSS
- GHSA-gj26-w59c-29mf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences