Read the docs
TI-2026-03363 Aliases CVE-2026-3888GHSA-grpw-jgrw-ccqr

Local Privilege Escalation in snapd

Priority LOW 39CWE-268Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

Local privilege escalation in snapd on Linux allows local attackers to get root privilege by re-creating snap's private /tmp directory when systemd-tmpfiles is configured to automatically clean up this directory. This issue affects Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 24.04 LTS.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01411 72nd percentileScored 2026-11-07
Fix Fixed snapd: 2.75.1Ubuntu 16.04 LTS (Canonical): 2.61.4ubuntu0.16.04.1+esm2+4 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—snapdbefore 2.75.12.75.1Patch availableCNA
CanonicalUbuntu 16.04 LTS—2.61.4ubuntu0.16.04.1+esm2Patch availableCNA
CanonicalUbuntu 18.04 LTS—2.61.4ubuntu0.18.04.1+esm2Patch availableCNA
CanonicalUbuntu 20.04 LTS—2.67.1+20.04ubuntu1~esm1Patch availableCNA
CanonicalUbuntu 22.04 LTS—2.73+ubuntu22.04.1Patch availableCNA
CanonicalUbuntu 24.04 LTS—2.73+ubuntu24.04.2Patch availableCNA
  • snapd Vendor— Affected before 2.75.1 Fixed in 2.75.1 Patch available CNA
  • Ubuntu 16.04 LTS VendorCanonical Affected — Fixed in 2.61.4ubuntu0.16.04.1+esm2 Patch available CNA
  • Ubuntu 18.04 LTS VendorCanonical Affected — Fixed in 2.61.4ubuntu0.18.04.1+esm2 Patch available CNA
  • Ubuntu 20.04 LTS VendorCanonical Affected — Fixed in 2.67.1+20.04ubuntu1~esm1 Patch available CNA
  • Ubuntu 22.04 LTS VendorCanonical Affected — Fixed in 2.73+ubuntu22.04.1 Patch available CNA
  • Ubuntu 24.04 LTS VendorCanonical Affected — Fixed in 2.73+ubuntu24.04.2 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*16.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*20.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:*22.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:24.04:*:*:*:lts:*:*:*24.04VulnerableCanonical
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:* Versions 22.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:24.04:*:*:*:lts:*:*:* Versions 24.04 Vulnerable ·Canonical

Remediation

  • Fix · CNA snapd Fixed in 2.75.1
  • Fix · CNA Ubuntu 16.04 LTS (Canonical) Fixed in 2.61.4ubuntu0.16.04.1+esm2
  • Fix · CNA Ubuntu 18.04 LTS (Canonical) Fixed in 2.61.4ubuntu0.18.04.1+esm2
  • Fix · CNA Ubuntu 20.04 LTS (Canonical) Fixed in 2.67.1+20.04ubuntu1~esm1
  • Fix · CNA Ubuntu 22.04 LTS (Canonical) Fixed in 2.73+ubuntu22.04.1
  • Fix · CNA Ubuntu 24.04 LTS (Canonical) Fixed in 2.73+ubuntu24.04.2

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3888
  2. 2026-10-03 Alias added: GHSA-grpw-jgrw-ccqr
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
See all 4120 →

Sources