Read the docs
TI-2026-04045 Aliases CVE-2026-4646GHSA-rmvv-8v8w-rf7x

Insufficient input validation in GitHub plugin API causes denial of service

Priority LOW 20CWE-1287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint.. Mattermost Advisory ID: MMSA-2026-00638

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0025 16th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.7.0, 11.6.1, 11.5.4 +2github.com/mattermost/mattermost-server (Go): 11.6.1, 11.5.4, 11.4.5 +1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MattermostMattermost11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.1411.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15Patch availableCNA
—github.com/mattermost/mattermost-server (Go)11.6.0 to before 11.6.111.6.1Patch availableGHSA-rmvv-8v8w-rf7x
—github.com/mattermost/mattermost-server (Go)11.5.0 to before 11.5.411.5.4Patch availableGHSA-rmvv-8v8w-rf7x
—github.com/mattermost/mattermost-server (Go)11.4.0 to before 11.4.511.4.5Patch availableGHSA-rmvv-8v8w-rf7x
—github.com/mattermost/mattermost-server (Go)10.11.0 to before 10.11.1510.11.15Patch availableGHSA-rmvv-8v8w-rf7x
—github.com/mattermost/mattermost-plugin-github (Go)before 1.0.1-0.20260330164815-c2840e980b3c1.0.1-0.20260330164815-c2840e980b3cPatch availableGHSA-rmvv-8v8w-rf7x
  • Mattermost VendorMattermost Affected 11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.14 Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15 Patch available CNA
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.6.0 to before 11.6.1 Fixed in 11.6.1 Patch available GHSA-rmvv-8v8w-rf7x
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.5.0 to before 11.5.4 Fixed in 11.5.4 Patch available GHSA-rmvv-8v8w-rf7x
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.4.0 to before 11.4.5 Fixed in 11.4.5 Patch available GHSA-rmvv-8v8w-rf7x
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0 to before 10.11.15 Fixed in 10.11.15 Patch available GHSA-rmvv-8v8w-rf7x
  • github.com/mattermost/mattermost-plugin-github (Go) Vendor— Affected before 1.0.1-0.20260330164815-c2840e980b3c Fixed in 1.0.1-0.20260330164815-c2840e980b3c Patch available GHSA-rmvv-8v8w-rf7x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:*10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1VulnerableMattermost
  • cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1 Vulnerable ·Mattermost

Remediation

  • Fix · CNA Mattermost (Mattermost) Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15
  • Fix · GHSA-rmvv-8v8w-rf7x github.com/mattermost/mattermost-server (Go) Fixed in 11.6.1 Advisory →
  • Fix · GHSA-rmvv-8v8w-rf7x github.com/mattermost/mattermost-server (Go) Fixed in 11.5.4 Advisory →
  • Fix · GHSA-rmvv-8v8w-rf7x github.com/mattermost/mattermost-server (Go) Fixed in 11.4.5 Advisory →
  • Fix · GHSA-rmvv-8v8w-rf7x github.com/mattermost/mattermost-server (Go) Fixed in 10.11.15 Advisory →
  • Fix · GHSA-rmvv-8v8w-rf7x github.com/mattermost/mattermost-plugin-github (Go) Fixed in 1.0.1-0.20260330164815-c2840e980b3c Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-4646
  2. 2026-10-03 Alias added: GHSA-rmvv-8v8w-rf7x

References

  • TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
  • TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
  • TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
  • TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
  • TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
  • TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
See all 505 →

Sources