Missing request body size limits on Zoom plugin HTTP endpoints
Priority LOW 32CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to enforce request body size limits on plugin HTTP endpoints which allows an attacker to cause a denial of service via crafted oversized HTTP requests.. Mattermost Advisory ID: MMSA-2026-00646
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00254 17th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.7.0, 11.6.1, 11.5.4 +2github.com/mattermost/mattermost-server (Go): 11.6.1, 11.5.4, 11.4.5 +1+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.14 | 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15 | Patch available | CNA |
| — | github.com/mattermost/mattermost-server (Go) | 11.6.0 to before 11.6.1 | 11.6.1 | Patch available | GHSA-jmvr-r5hm-fxfr |
| — | github.com/mattermost/mattermost-server (Go) | 11.5.0 to before 11.5.4 | 11.5.4 | Patch available | GHSA-jmvr-r5hm-fxfr |
| — | github.com/mattermost/mattermost-server (Go) | 11.4.0 to before 11.4.5 | 11.4.5 | Patch available | GHSA-jmvr-r5hm-fxfr |
| — | github.com/mattermost/mattermost-server (Go) | 10.11.0 to before 10.11.15 | 10.11.15 | Patch available | GHSA-jmvr-r5hm-fxfr |
| — | github.com/mattermost/mattermost-plugin-github (Go) | before 1.0.1-0.20260410143745-9b41b1fd43c4 | 1.0.1-0.20260410143745-9b41b1fd43c4 | Patch available | GHSA-jmvr-r5hm-fxfr |
- Mattermost VendorMattermost Affected 11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.14 Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15 Patch available CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.6.0 to before 11.6.1 Fixed in 11.6.1 Patch available GHSA-jmvr-r5hm-fxfr
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.5.0 to before 11.5.4 Fixed in 11.5.4 Patch available GHSA-jmvr-r5hm-fxfr
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.4.0 to before 11.4.5 Fixed in 11.4.5 Patch available GHSA-jmvr-r5hm-fxfr
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0 to before 10.11.15 Fixed in 10.11.15 Patch available GHSA-jmvr-r5hm-fxfr
- github.com/mattermost/mattermost-plugin-github (Go) Vendor— Affected before 1.0.1-0.20260410143745-9b41b1fd43c4 Fixed in 1.0.1-0.20260410143745-9b41b1fd43c4 Patch available GHSA-jmvr-r5hm-fxfr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15
- Fix · GHSA-jmvr-r5hm-fxfr github.com/mattermost/mattermost-server (Go) Fixed in 11.6.1 Advisory →
- Fix · GHSA-jmvr-r5hm-fxfr github.com/mattermost/mattermost-server (Go) Fixed in 11.5.4 Advisory →
- Fix · GHSA-jmvr-r5hm-fxfr github.com/mattermost/mattermost-server (Go) Fixed in 11.4.5 Advisory →
- Fix · GHSA-jmvr-r5hm-fxfr github.com/mattermost/mattermost-server (Go) Fixed in 10.11.15 Advisory →
- Fix · GHSA-jmvr-r5hm-fxfr github.com/mattermost/mattermost-plugin-github (Go) Fixed in 1.0.1-0.20260410143745-9b41b1fd43c4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-5308
- 2026-10-03 Alias added: GHSA-jmvr-r5hm-fxfr
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-5308 · CVE Program
- CVE-2026-5308 · NVD
- FIRST EPSS
- GHSA-jmvr-r5hm-fxfr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences