Read the docs
TI-2026-05033 Aliases CVE-2026-5740GHSA-w9m8-p4cc-4qj9

Unauthenticated WebSocket binary frame causes denial of service in Mattermost Server

Priority LOW 39CWE-789Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-789.

Summary

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to properly validate msgpack-encoded WebSocket frames before memory allocation which allows an unauthenticated remote attacker to crash the server process and cause a full service outage for all users via a crafted binary WebSocket message sent to the public WebSocket endpoint.. Mattermost Advisory ID: MMSA-2026-00647

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.7.0, 11.6.1, 11.5.4 +2github.com/mattermost/mattermost-server (Go): 11.6.1, 11.5.4, 11.4.5 +1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MattermostMattermost11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.1411.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15Patch availableCNA
—github.com/mattermost/mattermost-server (Go)11.6.0 to before 11.6.111.6.1Patch availableGHSA-w9m8-p4cc-4qj9
—github.com/mattermost/mattermost-server (Go)11.5.0 to before 11.5.411.5.4Patch availableGHSA-w9m8-p4cc-4qj9
—github.com/mattermost/mattermost-server (Go)11.4.0 to before 11.4.511.4.5Patch availableGHSA-w9m8-p4cc-4qj9
—github.com/mattermost/mattermost-server (Go)10.11.0 to before 10.11.1510.11.15Patch availableGHSA-w9m8-p4cc-4qj9
—github.com/mattermost/mattermost/server/v8 (Go)before 8.0.0-20260410202636-17939826efa28.0.0-20260410202636-17939826efa2Patch availableGHSA-w9m8-p4cc-4qj9
  • Mattermost VendorMattermost Affected 11.6.0 – 11.6.0; 11.5.0 – 11.5.3; 11.4.0 – 11.4.4; 10.11.0 – 10.11.14 Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15 Patch available CNA
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.6.0 to before 11.6.1 Fixed in 11.6.1 Patch available GHSA-w9m8-p4cc-4qj9
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.5.0 to before 11.5.4 Fixed in 11.5.4 Patch available GHSA-w9m8-p4cc-4qj9
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.4.0 to before 11.4.5 Fixed in 11.4.5 Patch available GHSA-w9m8-p4cc-4qj9
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0 to before 10.11.15 Fixed in 10.11.15 Patch available GHSA-w9m8-p4cc-4qj9
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20260410202636-17939826efa2 Fixed in 8.0.0-20260410202636-17939826efa2 Patch available GHSA-w9m8-p4cc-4qj9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:*10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1VulnerableMattermost
  • cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.15; 11.4.0 to before 11.4.5; 11.5.0 to before 11.5.4; 11.6.0 to before 11.6.1 Vulnerable ·Mattermost

Remediation

  • Fix · CNA Mattermost (Mattermost) Fixed in 11.7.0, 11.6.1, 11.5.4, 11.4.5, 10.11.15
  • Fix · GHSA-w9m8-p4cc-4qj9 github.com/mattermost/mattermost-server (Go) Fixed in 11.6.1 Advisory →
  • Fix · GHSA-w9m8-p4cc-4qj9 github.com/mattermost/mattermost-server (Go) Fixed in 11.5.4 Advisory →
  • Fix · GHSA-w9m8-p4cc-4qj9 github.com/mattermost/mattermost-server (Go) Fixed in 11.4.5 Advisory →
  • Fix · GHSA-w9m8-p4cc-4qj9 github.com/mattermost/mattermost-server (Go) Fixed in 10.11.15 Advisory →
  • Fix · GHSA-w9m8-p4cc-4qj9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260410202636-17939826efa2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-5740
  2. 2026-10-03 Alias added: GHSA-w9m8-p4cc-4qj9
  3. 2026-10-25 Priority changed: MEDIUM → LOW

References

  • TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
  • TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
  • TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
  • TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
  • TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
  • TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
See all 505 →

Sources