Cross-site scripting in servmask All-in-One WP Migration Unlimited Extension
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The All-in-One WP Migration Unlimited Extension plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ai1wm_backups_path' parameter in all versions up to, and including, 2.84. This is due to insufficient input sanitization and output escaping on user-supplied attributes combined with missing authorization checks on the settings() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the plugin settings page. The vulnerability was partially patched in version 2.84.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6128
- 2026-10-03 Alias added: GHSA-vh38-jq6h-xh79
References
More servmask vulnerabilities
- TI-2023-20896 Unauth. Access Token Manipulation vulnerability in multiple ServMask WordPress plugins CVSS 3.1HIGH 7.3
- TI-2024-08507 All-in-One WP Migration and Backup <= 7.86 - Authenticated (Administrator+) Arbitrary PHP Code Injection CVSS 3.1HIGH 7.2
- TI-2022-01350 All-in-One WP Migration <= 7.58 - Directory Traversal to File Deletion on Windows Hosts CVSS 3.1MEDIUM 6.6
- TI-2022-02352 All-in-One WP Migration < 7.63 - Unauthenticated Reflected XSS CVSS 3.1MEDIUM 4.7
- TI-2026-16173 SQL injection in servmask All-in-One WP Migration and Backup CVSS 3.1HIGH 8.8
- TI-2024-10143 All in One WP Migration <= 7.89 - Unauthenticated PHP Object Injection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-6128 · CVE Program
- CVE-2026-6128 · NVD
- FIRST EPSS
- GHSA-vh38-jq6h-xh79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences