Incorrect authorization in Mattermost
Priority LOW 19CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to check public/private permissions which allows members without these permissions to access public playbooks via /get.. Mattermost Advisory ID: MMSA-2026-00591
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00165 5th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.6.0, 11.5.2, 10.11.14 +1github.com/mattermost/mattermost/server/v8 (Go): 11.5.2, 11.4.4, 10.11.14+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.5.0 – 11.5.1; 10.11.0 – 10.11.13; 11.4.0 – 11.4.3 | 11.6.0, 11.5.2, 10.11.14, 11.4.4 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 11.5.0 to before 11.5.2 | 11.5.2 | Patch available | GHSA-m79q-8qf5-v622 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 11.4.0 to before 11.4.4 | 11.4.4 | Patch available | GHSA-m79q-8qf5-v622 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.11.0 to before 10.11.14 | 10.11.14 | Patch available | GHSA-m79q-8qf5-v622 |
| — | github.com/mattermost/mattermost-plugin-playbooks (Go) | before 1.41.1-0.20260309184833-887d9cacb616 | 1.41.1-0.20260309184833-887d9cacb616 | Patch available | GHSA-m79q-8qf5-v622 |
- Mattermost VendorMattermost Affected 11.5.0 – 11.5.1; 10.11.0 – 10.11.13; 11.4.0 – 11.4.3 Fixed in 11.6.0, 11.5.2, 10.11.14, 11.4.4 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.5.0 to before 11.5.2 Fixed in 11.5.2 Patch available GHSA-m79q-8qf5-v622
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.4.0 to before 11.4.4 Fixed in 11.4.4 Patch available GHSA-m79q-8qf5-v622
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.11.0 to before 10.11.14 Fixed in 10.11.14 Patch available GHSA-m79q-8qf5-v622
- github.com/mattermost/mattermost-plugin-playbooks (Go) Vendor— Affected before 1.41.1-0.20260309184833-887d9cacb616 Fixed in 1.41.1-0.20260309184833-887d9cacb616 Patch available GHSA-m79q-8qf5-v622
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.14; 11.4.0 to before 11.4.4; 11.5.0 to before 11.5.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.14; 11.4.0 to before 11.4.4; 11.5.0 to before 11.5.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.6.0, 11.5.2, 10.11.14, 11.4.4
- Fix · GHSA-m79q-8qf5-v622 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.5.2 Advisory →
- Fix · GHSA-m79q-8qf5-v622 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.4.4 Advisory →
- Fix · GHSA-m79q-8qf5-v622 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.11.14 Advisory →
- Fix · GHSA-m79q-8qf5-v622 github.com/mattermost/mattermost-plugin-playbooks (Go) Fixed in 1.41.1-0.20260309184833-887d9cacb616 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6343
- 2026-10-03 Alias added: GHSA-m79q-8qf5-v622
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-6343 · CVE Program
- CVE-2026-6343 · NVD
- FIRST EPSS
- GHSA-m79q-8qf5-v622 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences