Read the docs
TI-2026-05567 Aliases CVE-2026-6346GHSA-9p64-jpc7-m2rp

Sensitive credentials exposed in plaintext in Mattermost support packets

Priority LOW 39CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before including them in support packet generation, which allows a Mattermost System Admin or any party with access to a support packet to obtain sensitive credentials in plaintext via downloading a support packet from the System Console.. Mattermost Advisory ID: MMSA-2026-00607

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00301 22nd percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.6.0, 11.5.2, 10.11.14 +1github.com/mattermost/mattermost/server/v8 (Go): 11.5.2, 10.11.14, 11.4.4 +1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MattermostMattermost11.5.0 – 11.5.1; 10.11.0 – 10.11.13; 11.4.0 – 11.4.311.6.0, 11.5.2, 10.11.14, 11.4.4Patch availableCNA
—github.com/mattermost/mattermost/server/v8 (Go)11.5.0 to before 11.5.211.5.2Patch availableGHSA-9p64-jpc7-m2rp
—github.com/mattermost/mattermost/server/v8 (Go)10.11.0 to before 10.11.1410.11.14Patch availableGHSA-9p64-jpc7-m2rp
—github.com/mattermost/mattermost/server/v8 (Go)11.4.0 to before 11.4.411.4.4Patch availableGHSA-9p64-jpc7-m2rp
—github.com/mattermost/mattermost/server/v8 (Go)before 8.0.0-20260326202606-fac92f4a71f38.0.0-20260326202606-fac92f4a71f3Patch availableGHSA-9p64-jpc7-m2rp
—github.com/mattermost/mattermost-server (Go)before 5.3.2-0.20260326202606-fac92f4a71f35.3.2-0.20260326202606-fac92f4a71f3Patch availableGHSA-9p64-jpc7-m2rp
  • Mattermost VendorMattermost Affected 11.5.0 – 11.5.1; 10.11.0 – 10.11.13; 11.4.0 – 11.4.3 Fixed in 11.6.0, 11.5.2, 10.11.14, 11.4.4 Patch available CNA
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.5.0 to before 11.5.2 Fixed in 11.5.2 Patch available GHSA-9p64-jpc7-m2rp
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.11.0 to before 10.11.14 Fixed in 10.11.14 Patch available GHSA-9p64-jpc7-m2rp
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 11.4.0 to before 11.4.4 Fixed in 11.4.4 Patch available GHSA-9p64-jpc7-m2rp
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20260326202606-fac92f4a71f3 Fixed in 8.0.0-20260326202606-fac92f4a71f3 Patch available GHSA-9p64-jpc7-m2rp
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected before 5.3.2-0.20260326202606-fac92f4a71f3 Fixed in 5.3.2-0.20260326202606-fac92f4a71f3 Patch available GHSA-9p64-jpc7-m2rp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:*10.11.0 to before 10.11.14; 11.4.0 to before 11.4.4; 11.5.0 to before 11.5.2VulnerableMattermost
  • cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.14; 11.4.0 to before 11.4.4; 11.5.0 to before 11.5.2 Vulnerable ·Mattermost

Remediation

  • Fix · CNA Mattermost (Mattermost) Fixed in 11.6.0, 11.5.2, 10.11.14, 11.4.4
  • Fix · GHSA-9p64-jpc7-m2rp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.5.2 Advisory →
  • Fix · GHSA-9p64-jpc7-m2rp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.11.14 Advisory →
  • Fix · GHSA-9p64-jpc7-m2rp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 11.4.4 Advisory →
  • Fix · GHSA-9p64-jpc7-m2rp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260326202606-fac92f4a71f3 Advisory →
  • Fix · GHSA-9p64-jpc7-m2rp github.com/mattermost/mattermost-server (Go) Fixed in 5.3.2-0.20260326202606-fac92f4a71f3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-6346
  2. 2026-10-03 Alias added: GHSA-9p64-jpc7-m2rp
  3. 2026-10-25 Priority changed: MEDIUM → LOW

References

  • TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
  • TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
  • TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
  • TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
  • TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
  • TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
See all 505 →

Sources