PostgreSQL pg_createsubscriber allows SQL injection via subscription name
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-89.
Summary
SQL injection in PostgreSQL pg_createsubscriber allows an attacker with pg_create_subscription rights to execute arbitrary SQL as a superuser. The attack takes effect when pg_createsubscriber next runs. Within major versions 17 and 18, minor versions before PostgreSQL 18.4 and 17.10 are affected. Versions before PostgreSQL 17 are unaffected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PostgreSQL | 18 to before 18.4; 17 to before 17.10 | 18.4, 17.10 | Patch available | CNA |
- PostgreSQL Vendor— Affected 18 to before 18.4; 17 to before 17.10 Fixed in 18.4, 17.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* | 17.0 to before 17.10; 18.0 to before 18.4 | Vulnerable | PostgreSQL |
- cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions 17.0 to before 17.10; 18.0 to before 18.4 Vulnerable ·PostgreSQL
Remediation
- Fix · CNA PostgreSQL Fixed in 18.4, 17.10
Red Hat 5 advisories
- RHSA-2026:67848 Released 2026-09-16 · Red Hat rating Importantpostgresql:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.aarch64::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.ppc64le::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.s390x::postgresql:18 +47
- RHSA-2026:67280 Released 2026-09-14 · Red Hat rating Importantpostgresql18 security update
- Red Hat Enterprise Linux AppStream (v. 10) postgresql18-18.6-1.el10_2, postgresql18-contrib-18.6-1.el10_2, postgresql18-docs-18.6-1.el10_2 +10
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) postgresql18-test-rpm-macros-18.6-1.el10_2
- RHSA-2026:27742 Released 2026-06-22 · Red Hat rating Importantpostgresql18 security update
- Red Hat Enterprise Linux AppStream (v. 10) postgresql18-18.4-1.el10_2, postgresql18-contrib-18.4-1.el10_2, postgresql18-docs-18.4-1.el10_2 +10
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) postgresql18-test-rpm-macros-18.4-1.el10_2
Show 2 more Red Hat advisories
- RHSA-2026:26204 Released 2026-06-16 · Red Hat rating Importantpostgresql:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.aarch64::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.ppc64le::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.s390x::postgresql:18 +47
- RHSA-2026:22878 Released 2026-06-03 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images postgresql-18.4-0.1.hum1@aarch64, postgresql-18.4-0.1.hum1@x86_64, postgresql-contrib-18.4-0.1.hum1@aarch64 +26
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:27742, RHSA-2026:67280 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:26204, RHSA-2026:67848 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:27742, RHSA-2026:67280 |
| Red Hat Hardened Images | Fixed | RHSA-2026:22878 |
Not affected: 7 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Hardened Images
- Self-service automation portal 2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6476
- 2026-10-03 Alias added: GHSA-9crw-q654-rwgr
References
More Postgresql vulnerabilities
- TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
- TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
- TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
- TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
- TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
- TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2026-6476 · CVE Program
- CVE-2026-6476 · NVD
- FIRST EPSS
- GHSA-9crw-q654-rwgr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-6476 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences