PostgreSQL pg_restore_attribute_stats accepts values that cause query planning to read past end of stats array
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-126 and the CVSS impact.
Summary
Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array. This allows a table maintainer to infer memory values past that array end. Within major version 18, minor versions before PostgreSQL 18.4 are affected. Versions before PostgreSQL 18 are unaffected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PostgreSQL | 18 to before 18.4 | 18.4 | Patch available | CNA |
- PostgreSQL Vendor— Affected 18 to before 18.4 Fixed in 18.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* | 18.0 to before 18.4 | Vulnerable | PostgreSQL |
- cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions 18.0 to before 18.4 Vulnerable ·PostgreSQL
Remediation
- Fix · CNA PostgreSQL Fixed in 18.4
Red Hat 4 advisories
- RHSA-2026:27742 Released 2026-06-22 · Red Hat rating Importantpostgresql18 security update
- Red Hat Enterprise Linux AppStream (v. 10) postgresql18-18.4-1.el10_2, postgresql18-contrib-18.4-1.el10_2, postgresql18-docs-18.4-1.el10_2 +10
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) postgresql18-test-rpm-macros-18.4-1.el10_2
- RHSA-2026:26204 Released 2026-06-16 · Red Hat rating Importantpostgresql:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.aarch64::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.ppc64le::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.s390x::postgresql:18 +47
- RHSA-2026:22878 Released 2026-06-03 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images postgresql-18.4-0.1.hum1@aarch64, postgresql-18.4-0.1.hum1@x86_64, postgresql-contrib-18.4-0.1.hum1@aarch64 +26
Show 1 more Red Hat advisories
- RHSA-2026:21182 Released 2026-05-26 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images postgresql17-17.10-0.1.hum1@aarch64, postgresql17-17.10-0.1.hum1@src, postgresql17-17.10-0.1.hum1@x86_64 +28
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:27742 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:26204 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:27742 |
| Red Hat Hardened Images | Fixed | RHSA-2026:21182, RHSA-2026:22878 |
Not affected: 6 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Hardened Images
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6575
- 2026-10-03 Alias added: GHSA-f8xc-gmqx-v9fh
References
More Postgresql vulnerabilities
- TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
- TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
- TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
- TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
- TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
- TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2026-6575 · CVE Program
- CVE-2026-6575 · NVD
- FIRST EPSS
- GHSA-f8xc-gmqx-v9fh · GitHub Advisory Database · CC BY 4.0
- CVE-2026-6575 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences