Read the docs
TI-2026-05891 Aliases CVE-2026-6725GHSA-hj4x-4m97-wrwh

Cross-site scripting in wpclever WPC Smart Messages for WooCommerce

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The WPC Smart Messages for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'text' attribute of the `wpcsm_text_rotator` shortcode in all versions up to, and including, 4.2.8. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00188 8th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpcleverWPC Smart Messages for WooCommerceup to 4.2.8—No fix listedCNA
  • WPC Smart Messages for WooCommerce Vendorwpclever Affected up to 4.2.8 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-6725
  2. 2026-10-03 Alias added: GHSA-hj4x-4m97-wrwh

References

  • TI-2024-33849 WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-22095 WordPress WPC Smart Linked Products plugin <= 1.3.5 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-22042 Missing authorization in wpclever WPC Smart Upsell Funnel for WooCommerce CVSS 3.1HIGH 8.8
  • TI-2024-09664 WPC Smart Messages for WooCommerce <= 4.2.1 - Authenticated (Subscriber+) Local File Inclusion CVSS 3.1HIGH 8.8
  • TI-2026-63681 Improper privilege management in wpclever WPC Shop as a Customer for WooCommerce CVSS 3.1HIGH 8.8
  • TI-2025-03002 WPC Admin Columns 2.0.6 - 2.1.0 - Authenticated (Subscriber+) Privilege Escalation via User Meta Update CVSS 3.1HIGH 8.8
See all 40 →

Sources