Read the docs
TI-2026-06101 Aliases CVE-2026-6970GHSA-fg3j-5w9g-hmg7

authd Denial of Service and Local Privilege Escalation

Priority LOW 33CWE-842Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and the user's identity provider record is updated, authd incorrectly resets the user's primary group ID to their UID upon next login. This causes newly created files and directories to be owned by the wrong group, causing denial of service issues, and potentially granting unintended access to other local users and allowing local privilege escalation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0011 1st percentileScored 2026-11-07
Fix Fixed authd (Canonical): 0.6.4, 0.6.1ubuntu0.1github.com/canonical/authd (Go): 0.6.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Canonicalauthd0.6.0 to before 0.6.4; 0.6.1 to before 0.6.1ubuntu0.10.6.4, 0.6.1ubuntu0.1Patch availableCNA
—github.com/canonical/authd (Go)0.6.0 to before 0.6.40.6.4Patch availableGHSA-fg3j-5w9g-hmg7
  • authd VendorCanonical Affected 0.6.0 to before 0.6.4; 0.6.1 to before 0.6.1ubuntu0.1 Fixed in 0.6.4, 0.6.1ubuntu0.1 Patch available CNA
  • github.com/canonical/authd (Go) Vendor— Affected 0.6.0 to before 0.6.4 Fixed in 0.6.4 Patch available GHSA-fg3j-5w9g-hmg7

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:canonical:authd:*:*:*:*:*:*:*:*——Canonical
  • cpe:2.3:a:canonical:authd:*:*:*:*:*:*:*:* Versions — — ·Canonical

Remediation

  • Fix · CNA authd (Canonical) Fixed in 0.6.4, 0.6.1ubuntu0.1
  • Fix · GHSA-fg3j-5w9g-hmg7 github.com/canonical/authd (Go) Fixed in 0.6.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-6970
  2. 2026-10-03 Alias added: GHSA-fg3j-5w9g-hmg7

References

  • TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
See all 4301 →

Sources