Cross-site scripting in wpclever WPC Badge Management for WooCommerce
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WPC Badge Management for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'text' attribute of the `wpcbm_best_seller` shortcode in all versions up to, and including, 3.1.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-7436
- 2026-10-03 Alias added: GHSA-33hx-w9g7-6rmq
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/588e12c4-7d68-40ac-82bc-aacc5d389dee?source=cve
- https://wordpress.org/plugins/wpc-badge-management
- https://plugins.trac.wordpress.org/browser/wpc-badge-management/trunk/includes/class-shortcode.php#L141
- https://plugins.trac.wordpress.org/browser/wpc-badge-management/tags/3.1.5/includes/class-shortcode.php#L141
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3519100%40wpc-badge-management%2Ftrunk&old=3483376%40wpc-badge-management%2Ftrunk&sfp_email=&sfph_mail=
More wpclever vulnerabilities
- TI-2024-33849 WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22095 WordPress WPC Smart Linked Products plugin <= 1.3.5 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22042 Missing authorization in wpclever WPC Smart Upsell Funnel for WooCommerce CVSS 3.1HIGH 8.8
- TI-2024-09664 WPC Smart Messages for WooCommerce <= 4.2.1 - Authenticated (Subscriber+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2026-63681 Improper privilege management in wpclever WPC Shop as a Customer for WooCommerce CVSS 3.1HIGH 8.8
- TI-2025-03002 WPC Admin Columns 2.0.6 - 2.1.0 - Authenticated (Subscriber+) Privilege Escalation via User Meta Update CVSS 3.1HIGH 8.8
Sources
- CVE-2026-7436 · CVE Program
- CVE-2026-7436 · NVD
- FIRST EPSS
- GHSA-33hx-w9g7-6rmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences