langflow-ai langflow LambdaFilterComponent lambda_filter.py eval code injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A weakness has been identified in langflow-ai langflow up to 1.10.2. This affects the function eval of the file src/lfx/src/lfx/components/llm_operations/lambda_filter.py of the component LambdaFilterComponent. Executing a manipulation can lead to code injection. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Langflow | langflow | 1.10.0; 1.10.1; 1.10.2 | — | No fix listed | CNA |
| — | langflow (PyPI) | 1.3.0 to before 1.10.3 | 1.10.3 | Patch available | GHSA-9fpm-3445-2vx4 |
- langflow VendorLangflow Affected 1.10.0; 1.10.1; 1.10.2 Fixed in — No fix listed CNA
- langflow (PyPI) Vendor— Affected 1.3.0 to before 1.10.3 Fixed in 1.10.3 Patch available GHSA-9fpm-3445-2vx4
Remediation
- Fix · GHSA-9fpm-3445-2vx4 langflow (PyPI) Fixed in 1.10.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-7700
- 2026-10-03 Alias added: GHSA-hhxr-7j22-694r
- 2026-10-06 Title updated · CNA
- 2026-10-06 Affected versions changed · CNA
- 2026-10-06 2 new references · CNA
- 2026-10-06 Alias added: GHSA-9fpm-3445-2vx4
- 2026-10-06 Fix available: PyPI/[email protected] · GHSA-9fpm-3445-2vx4
- 2026-10-06 CVSS score added · GHSA-9fpm-3445-2vx4
- 2026-10-06 Weakness changed · GHSA-9fpm-3445-2vx4
- 2026-10-06 8 new references · GHSA-9fpm-3445-2vx4
References
Other 7
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-9fpm-3445-2vx4
- https://github.com/langflow-ai/langflow/
- https://github.com/langflow-ai/langflow/pull/13530
- https://github.com/langflow-ai/langflow/commit/1641b28f33e2c47b9a0c6855922d44d1b8418b9d
- https://github.com/langflow-ai/langflow/commit/94859df33acd70b2a1f816e26d68f5e89a7e5639
- https://github.com/langflow-ai/langflow
- https://github.com/langflow-ai/langflow/releases/tag/v1.10.3
More Langflow vulnerabilities
- TI-2026-08085 Unauthenticated Remote Code Execution via Auto-Login Bypass and Code Validation KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00553 Langflow exec_globals Inclusion of Functionality from Untrusted Control Sphere Remote… KEVCVSS 3.0CRITICAL 9.8
- TI-2025-24427 Langflow <= 1.6.9 CORS Misconfiguration to Token Hijack & RCE KEVCVSS 4.0CRITICAL 9.4
- TI-2025-02845 Langflow < 1.3.0 Unauthenticated RCE via /api/v1/validate/code KEVCVSS 3.1CRITICAL 9.8
- TI-2026-25463 Langflow has Unauthenticated Remote Code Execution via Public Flow Build Endpoint KEVCVSS 4.0CRITICAL 9.3
- TI-2026-39928 Authorization bypass in langflow KEVCVSS 3.1HIGH 8.4
Sources
- CVE-2026-7700 · CVE Program
- CVE-2026-7700 · NVD
- FIRST EPSS
- GHSA-9fpm-3445-2vx4 · GitHub Advisory Database · CC BY 4.0
- GHSA-hhxr-7j22-694r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences