OSGeo gdal SWapi.c SWnentries heap-based overflow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A vulnerability was identified in OSGeo gdal up to 3.13.0dev-4. This issue affects the function SWnentries of the file frmts/hdf4/hdf-eos/SWapi.c. Such manipulation of the argument DimensionName leads to heap-based buffer overflow. The attack must be carried out locally. The exploit is publicly available and might be used. Upgrading to version 3.12.4RC1 is capable of addressing this issue. The name of the patch is 9491e794f1757f08063ea2f7a274ad2994afa636. It is advisable to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OSGeo | gdal | 3.13.0dev-4 | 3.12.4RC1 | Patch available | CNA |
- gdal VendorOSGeo Affected 3.13.0dev-4 Fixed in 3.12.4RC1 Patch available CNA
Remediation
- Fix · CNA gdal (OSGeo) Fixed in 3.12.4RC1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-8086
- 2026-10-03 Alias added: GHSA-72pg-5w29-wjx6
References
Exploit 2
Patch 3
More OSGeo Gdal vulnerabilities
- TI-2026-36264 Stack-based buffer overflow in GDAL CVSS 3.1HIGH 7.8
- TI-2025-21099 Buffer Overflow vulnerability in gdal 3.10.2 allows a local attacker to cause a denial of… CVSS 3.1MEDIUM 5.5
- TI-2026-07234 OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-07233 OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-07126 OSGeo gdal GDapi.c GDfieldinfo out-of-bounds CVSS 4.0MEDIUM 4.8
- TI-2026-07125 OSGeo gdal GDapi.c GDnentries heap-based overflow CVSS 4.0MEDIUM 4.8
Sources
- CVE-2026-8086 · CVE Program
- CVE-2026-8086 · NVD
- FIRST EPSS
- GHSA-72pg-5w29-wjx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences