Read the docs
TI-2026-07233 Aliases CVE-2026-8212GHSA-r5m4-5vww-w9f5

OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow

Priority MEDIUM 55CWE-119Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00205 10th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed gdal (OSGeo): 3.13.0RC1GDAL (PyPI): 3.13.0RC1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OSGeogdal3.13.0dev-43.13.0RC1Patch availableCNA
—GDAL (PyPI)before 3.13.0RC13.13.0RC1Patch availableGHSA-r5m4-5vww-w9f5
  • gdal VendorOSGeo Affected 3.13.0dev-4 Fixed in 3.13.0RC1 Patch available CNA
  • GDAL (PyPI) Vendor— Affected before 3.13.0RC1 Fixed in 3.13.0RC1 Patch available GHSA-r5m4-5vww-w9f5

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:osgeo:gdal:*:*:*:*:*:*:*:*up to 3.12.4VulnerableOSGeo
cpe:2.3:a:osgeo:gdal:3.13.0:beta1:*:*:*:*:*:*3.13.0 beta1VulnerableOSGeo
cpe:2.3:a:osgeo:gdal:3.13.0:beta2:*:*:*:*:*:*3.13.0 beta2VulnerableOSGeo
  • cpe:2.3:a:osgeo:gdal:*:*:*:*:*:*:*:* Versions up to 3.12.4 Vulnerable ·OSGeo
  • cpe:2.3:a:osgeo:gdal:3.13.0:beta1:*:*:*:*:*:* Versions 3.13.0 beta1 Vulnerable ·OSGeo
  • cpe:2.3:a:osgeo:gdal:3.13.0:beta2:*:*:*:*:*:* Versions 3.13.0 beta2 Vulnerable ·OSGeo

Remediation

  • Fix · CNA gdal (OSGeo) Fixed in 3.13.0RC1
  • Fix · GHSA-r5m4-5vww-w9f5 GDAL (PyPI) Fixed in 3.13.0RC1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-8212
  2. 2026-10-03 Alias added: GHSA-r5m4-5vww-w9f5

References

  • TI-2026-36264 Stack-based buffer overflow in GDAL CVSS 3.1HIGH 7.8
  • TI-2025-21099 Buffer Overflow vulnerability in gdal 3.10.2 allows a local attacker to cause a denial of… CVSS 3.1MEDIUM 5.5
  • TI-2026-07234 OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow CVSS 4.0MEDIUM 4.8
  • TI-2026-07126 OSGeo gdal GDapi.c GDfieldinfo out-of-bounds CVSS 4.0MEDIUM 4.8
  • TI-2026-07125 OSGeo gdal GDapi.c GDnentries heap-based overflow CVSS 4.0MEDIUM 4.8
  • TI-2026-07124 OSGeo gdal SWapi.c SWnentries heap-based overflow CVSS 4.0MEDIUM 4.8
See all 11 →

Sources