snap-confine Local Privilege Escalation via Capabilities Misconfiguration or Flaw in Execution Environment Setup
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-250.
Summary
A local privilege escalation vulnerability exists in snap-confine, a set-capabilities core component used internally by Canonical snapd to construct the secure execution environment for snap applications. This vulnerability uniquely affects versions of snap-confine configured with set-capabilities (rather than standard set-uid-root installations). Due to a flaw in how privilege boundaries or security sandboxes are initialized when the binary runs under limited ambient capabilities, a local, unprivileged attacker can exploit this behavior to bypass intended restrictions and execute arbitrary code. Successful exploitation allows the local user to elevate their privileges to full root authority.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | snapd | 2.75.0 to before 2.76.1 | 2.76.1 | Patch available | CNA |
| Canonical | Ubuntu 26.04 LTS | — | 2.76+ubuntu26.04.3 | Patch available | CNA |
| Canonical | Ubuntu 24.04 LTS | — | 2.76+ubuntu24.04.1 | Patch available | CNA |
| Canonical | Ubuntu 22.04 LTS | — | 2.76+ubuntu22.04.1 | Patch available | CNA |
- snapd Vendor— Affected 2.75.0 to before 2.76.1 Fixed in 2.76.1 Patch available CNA
- Ubuntu 26.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu26.04.3 Patch available CNA
- Ubuntu 24.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu24.04.1 Patch available CNA
- Ubuntu 22.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu22.04.1 Patch available CNA
Remediation
- Fix · CNA snapd Fixed in 2.76.1
- Fix · CNA Ubuntu 26.04 LTS (Canonical) Fixed in 2.76+ubuntu26.04.3
- Fix · CNA Ubuntu 24.04 LTS (Canonical) Fixed in 2.76+ubuntu24.04.1
- Fix · CNA Ubuntu 22.04 LTS (Canonical) Fixed in 2.76+ubuntu22.04.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-8933
- 2026-10-03 Alias added: GHSA-fxqr-j4gx-622c
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-8933 · CVE Program
- CVE-2026-8933 · NVD
- FIRST EPSS
- GHSA-fxqr-j4gx-622c · GitHub Advisory Database · CC BY 4.0
- CVE-2026-8933 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences