Dolibarr ERP CRM Leave Request REST API api_holidays.class.php checkUserAccessToObject improper authorization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266 and CWE-285.
Summary
A security vulnerability has been detected in Dolibarr ERP CRM up to 23.0.1. Impacted is the function checkUserAccessToObject of the file htdocs/holiday/class/api_holidays.class.php of the component Leave Request REST API. The manipulation leads to improper authorization. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 23.0.2 is recommended to address this issue. The identifier of the patch is ee93b6f2f9dd0f6aeefe9d718ab3ab0a44326b73. Upgrading the affected component is advised.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dolibarr | ERP CRM | 23.0.0; 23.0.1 | 23.0.2 | Patch available | CNA |
| — | dolibarr/dolibarr (Packagist) | up to 15.0.3 | — | No fix listed | GHSA-7fg5-vc77-69fp |
- ERP CRM VendorDolibarr Affected 23.0.0; 23.0.1 Fixed in 23.0.2 Patch available CNA
- dolibarr/dolibarr (Packagist) Vendor— Affected up to 15.0.3 Fixed in — No fix listed GHSA-7fg5-vc77-69fp
Remediation
- Fix · CNA ERP CRM (Dolibarr) Fixed in 23.0.2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-10215
- 2026-10-03 Alias added: GHSA-7fg5-vc77-69fp
References
Patch 2
More Dolibarr vulnerabilities
- TI-2022-21049 Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. CVSS 3.1CRITICAL 9.8
- TI-2022-03742 SQL Injection in dolibarr/dolibarr CVSS 3.1CRITICAL 9.8
- TI-2023-14191 Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an… CVSS 3.1HIGH 8.8
- TI-2018-15582 Dolibarr ERP CRM 7.0.3 Remote Code Execution via install/step1.php CVSS 4.0CRITICAL 9.3
- TI-2018-07157 SQL injection vulnerability in Dolibarr before 7.0.2 allows remote attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2019-15505 Dolibarr ERP/CRM 10.0.1 SQL Injection via elemid CVSS 4.0HIGH 8.8
Sources
- CVE-2026-10215 · CVE Program
- CVE-2026-10215 · NVD
- FIRST EPSS
- GHSA-7fg5-vc77-69fp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences