Improper signature verification in Pegasystems Pega Infinity
Priority MEDIUM 41CWE-347Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-347.
Summary
Pega Platform versions 8.5.0 through 25.1.2 are affected by an improper validation of cryptographic signatures that may allow an attacker to bypass security controls.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00777 56th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): Infinity 25.1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Infinity | 8.5.0 to before Infinity 25.1.3 | Infinity 25.1.3 | Patch available | CNA |
- Pega Infinity VendorPegasystems Affected 8.5.0 to before Infinity 25.1.3 Fixed in Infinity 25.1.3 Patch available CNA
Remediation
- Fix · CNA Pega Infinity (Pegasystems) Fixed in Infinity 25.1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-10754
- 2026-10-03 Alias added: GHSA-g9g7-h67p-37m6
References
More Pegasystems vulnerabilities
- TI-2021-09101 Improper authentication in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2022-08033 Deserialization of untrusted data in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2019-12313 Pega Platform 8.2.1 allows LDAP injection because a username can contain a * character… CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2026-11602 Pega Platform versions 7.1.0 through 25.1.2 are affected by an improper validation of… CVSS 4.0HIGH 8.8
Sources
- CVE-2026-10754 · CVE Program
- CVE-2026-10754 · NVD
- FIRST EPSS
- GHSA-g9g7-h67p-37m6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences