Authorization bypass in Metagauss ProfileGrid – User Profiles, Groups and Communities
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 5.9.9.5. This is due to the plugin not validating a `user_login` on registration forms that don't contain this parameter, and not properly handling the error messages. This makes it possible for unauthenticated attackers to change email address of user account with ID=1 (usually an administrator), and leverage that to reset the user's password and gain access to their account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12073
- 2026-10-03 Alias added: GHSA-5949-6pq3-mp7g
References
More Metagauss vulnerabilities
- TI-2023-00891 ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset CVSS 3.1HIGH 8.8
- TI-2021-07144 RegistrationMagic < 5.0.1.6 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2025-05982 Download Plugin <= 2.2.8 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2023-03938 EventPrime <= 3.2.9 - Booking Pricing Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-20215 WordPress ProfileGrid – User Profiles, Memberships, Groups and Communities plugin <= 5.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-04340 EventPrime – Events Calendar, Bookings and Tickets < 3.5.0 - Subscriber+ Arbitrary booking settings update CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-12073 · CVE Program
- CVE-2026-12073 · NVD
- FIRST EPSS
- GHSA-5949-6pq3-mp7g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences