Spectra Gutenberg Blocks <= 2.19.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via uagb/image Block
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Spectra Gutenberg Blocks – Website Builder for the Block Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `uagb/image` block in all versions up to, and including, 2.19.28 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | Spectra Legacy – Gutenberg Blocks | up to 2.19.28 | — | No fix listed | CNA |
- Spectra Legacy – Gutenberg Blocks VendorBrainstorm Force Affected up to 2.19.28 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12900
- 2026-10-03 Alias added: GHSA-3rp7-f8f5-j67m
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e9dc5e3-9d72-4c04-8ba9-56428a6fdddd?source=cve
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.28/blocks-config/image/class-uagb-image.php#L59
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.28/includes/blocks/image/block.php#L10
More Brainstorm Force vulnerabilities
- TI-2025-19878 WordPress SureTriggers <= 1.0.82 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-02708 Incorrect comparison in Brainstorm Force OttoKit: All-in-One Automation Platform CVSS 3.1HIGH 8.1
- TI-2025-05347 SureForms < 1.7.2 - Reflected XSS CVSS 3.1MEDIUM 5.8
- TI-2020-18849 Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting CVSS 3.1MEDIUM 5.4
- TI-2025-03050 SureForms < 1.4.4 - Contributor+ Settings Update CVSS 3.1MEDIUM 4.9
- TI-2025-11950 Starter Templates <= 4.4.41 - Authenticated (Author+) Arbitrary File Upload via WXR Upload Bypass CVSS 3.1HIGH 8.8
Sources
- CVE-2026-12900 · CVE Program
- CVE-2026-12900 · NVD
- FIRST EPSS
- GHSA-3rp7-f8f5-j67m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences