EventPrime <= 4.3.4.2 - Unauthenticated Stored Cross-Site Scripting via 'new_event_type_background_color' Parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The EventPrime – Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'new_event_type_background_color' parameter in all versions up to, and including, 4.3.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the plugin's Guest Submissions setting (allow_submission_by_anonymous_user) to be enabled, which allows unauthenticated attackers to submit event types via the frontend form; when that setting is disabled, exploitation requires at minimum a subscriber-level authenticated account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-13441
- 2026-10-03 Alias added: GHSA-566f-2h7m-xrh3
References
Other 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2abd400b-c633-4b38-ad3e-c9ce602ff07f?source=cve
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/tags/4.3.4.2/admin/class-eventprime-event-calendar-management-admin.php#L1973
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/tags/4.3.4.2/includes/class-ep-ajax.php#L1200
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/tags/4.3.4.2/includes/class-eventprime-functions.php#L9793
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/admin/class-eventprime-event-calendar-management-admin.php#L1973
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-ep-ajax.php#L1200
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-eventprime-functions.php#L9793
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3595157%40eventprime-event-calendar-management&new=3595157%40eventprime-event-calendar-management
More Metagauss vulnerabilities
- TI-2023-00891 ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset CVSS 3.1HIGH 8.8
- TI-2021-07144 RegistrationMagic < 5.0.1.6 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2025-05982 Download Plugin <= 2.2.8 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2023-03938 EventPrime <= 3.2.9 - Booking Pricing Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-20215 WordPress ProfileGrid – User Profiles, Memberships, Groups and Communities plugin <= 5.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-04340 EventPrime – Events Calendar, Bookings and Tickets < 3.5.0 - Subscriber+ Arbitrary booking settings update CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-13441 · CVE Program
- CVE-2026-13441 · NVD
- FIRST EPSS
- GHSA-566f-2h7m-xrh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences