Read the docs
TI-2026-12367 Aliases CVE-2026-14673GHSA-qp83-ppf3-v924

PostgreSQL amcheck does not clear untrusted search path

Priority LOW 18CWE-426Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 fixed, 4 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-426.

Summary

Untrusted search path in PostgreSQL amcheck allows a grantee of amcheck function EXECUTE privilege to execute arbitrary functions as the owners of expression indexes that depend on the search path, via setting a hostile search path before calling the amcheck function. Within major versions 18, 16, 15, and 14, minor versions before PostgreSQL 18.6, 16.15, 15.19, and 14.24 are affected. PostgreSQL 17 is unaffected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00269 19th percentileScored 2026-11-07
Fix Partial PostgreSQL: 18.6, 16.15, 15.19 +1Red Hat: 2 advisoriesRed Hat: 1 fixed, 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—PostgreSQL18 to before 18.6; 16 to before 16.15; 15 to before 15.19; before 14.2418.6, 16.15, 15.19, 14.24Patch availableCNA
  • PostgreSQL Vendor— Affected 18 to before 18.6; 16 to before 16.15; 15 to before 15.19; before 14.24 Fixed in 18.6, 16.15, 15.19, 14.24 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*14.0 to before 14.24; 15.0 to before 15.19; 16.0 to before 16.15; 18.0 to before 18.5VulnerablePostgreSQL
  • cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions 14.0 to before 14.24; 15.0 to before 15.19; 16.0 to before 16.15; 18.0 to before 18.5 Vulnerable ·PostgreSQL

Remediation

  • Fix · CNA PostgreSQL Fixed in 18.6, 16.15, 15.19, 14.24

Red Hat 2 advisories

  • RHSA-2026:57198 Released 2026-08-20 · Red Hat rating Important
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images postgresql17-17.11-1.hum1@aarch64, postgresql17-17.11-1.hum1@src, postgresql17-17.11-1.hum1@x86_64 +28
  • RHSA-2026:54751 Released 2026-08-13 · Red Hat rating Moderate
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images postgresql-18.6-0.1.hum1@aarch64, postgresql-18.6-0.1.hum1@x86_64, postgresql-contrib-18.6-0.1.hum1@aarch64 +26

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 8AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred
Self-service automation portal 2AffectedNo fix yet: Fix deferred
Red Hat Hardened ImagesFixed RHSA-2026:54751, RHSA-2026:57198
Not affected: 3 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Hardened Images

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-14673
  2. 2026-10-03 Alias added: GHSA-qp83-ppf3-v924
  3. 2026-11-06 Affected versions changed · Red Hat

References

  • TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
  • TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
  • TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
  • TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
  • TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
  • TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
See all 202 →

Sources