WPFunnels <= 3.12.8 - Authenticated (Funnel Manager+) Privilege Escalation via 'group_id' Path Parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell plugin for WordPress is vulnerable to Privilege Escalation via arbitrary option update in all versions up to, and including, 3.12.8. This is due to the `update_settings()` REST callback failing to validate the `group_id` path parameter against an allowlist of permitted option names before passing it directly to `get_option()` and `update_option()`, allowing the built-in `wp_user_roles` option — which satisfies the route's loose `[\w-]+` regex — to be targeted. This makes it possible for authenticated attackers with the `wpf_manage_funnels` capability and above to elevate their privileges to administrator by writing a crafted role definition containing arbitrary capabilities into the `wp_user_roles` option, thereby granting any WordPress role full site administrator access. The `wpf_manage_funnels` capability is typically assigned to the Funnel Manager custom role created by the plugin, meaning this role is the minimum required to exploit the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getwpfunnels | WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell | up to 3.12.8 | — | No fix listed | CNA |
- WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell Vendorgetwpfunnels Affected up to 3.12.8 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15103
- 2026-10-03 Alias added: GHSA-qq4q-jv8x-6fjm
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/76ad6d21-f277-496f-aa6b-f9d5cb8a3801?source=cve
- https://plugins.trac.wordpress.org/browser/wpfunnels/tags/3.12.8/includes/core/rest-api/Controllers/class-settings-controller.php#L462
- https://plugins.trac.wordpress.org/browser/wpfunnels/tags/3.12.8/includes/core/rest-api/Controllers/class-settings-controller.php#L66
- https://plugins.trac.wordpress.org/browser/wpfunnels/tags/3.12.8/includes/core/rest-api/Controllers/class-settings-controller.php#L40
- https://plugins.trac.wordpress.org/browser/wpfunnels/tags/3.12.8/includes/utils/class-wpfnl-functions.php#L1216
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3607181%40wpfunnels&new=3607181%40wpfunnels
More getwpfunnels vulnerabilities
- TI-2023-00167 WPFunnels < 2.6.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2026-12131 WPFunnels <= 3.12.7 - Unauthenticated Remote Code Execution via 'postData' Parameter CVSS 3.1CRITICAL 9.8
- TI-2026-08934 Mail Mint <= 1.31.0 - Unauthenticated PHP Object Injection in Arbitrary Form Fields CVSS 3.1CRITICAL 9.8
- TI-2025-14000 Missing authorization in getwpfunnels Creator LMS – Online Courses and eLearning Plugin CVSS 3.1HIGH 8.8
- TI-2026-11129 WPFunnels <= 3.12.7 - Authenticated (Administrator+) Local File Inclusion via 'logKey' Parameter CVSS 3.1MEDIUM 6.6
- TI-2025-10973 Mail Mint <= 1.18.10 - Authenticated (Admin+) Arbitrary File Upload CVSS 3.1HIGH 7.2
Sources
- CVE-2026-15103 · CVE Program
- CVE-2026-15103 · NVD
- FIRST EPSS
- GHSA-qq4q-jv8x-6fjm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences