snapd snap-confine Sandbox Confinement Bypass via Omission of setuid Restriction in Seccomp Templates
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-250.
Summary
A sandbox confinement bypass vulnerability exists in Canonical snapd within its internal execution environment compiler (snap-confine). The default seccomp security templates generated by the engine to restrict system calls do not filter or reject process operations capable of creating or manipulating file execution flags with set-user-ID attributes. Consequently, an application running within a strictly confined snap environment can successfully compile or drop binaries and apply setuid properties to them. If a compromised or malicious process inside the snap sandbox executes these generated setuid binaries, it can potentially circumvent architectural sandboxing assumptions, drop intended restriction policies, or execute privileged actions inside the container namespace that should otherwise be strictly blocked. The vulnerability has been resolved by hardening the seccomp template engine to block the execution and creation of setuid executables by sandboxed snap processes.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | snapd | before 2.76.1 | 2.76.1 | Patch available | CNA |
| Canonical | Ubuntu 26.04 LTS | — | 2.76+ubuntu26.04.3 | Patch available | CNA |
| Canonical | Ubuntu 24.04 LTS | — | 2.76+ubuntu24.04.1 | Patch available | CNA |
| Canonical | Ubuntu 22.04 LTS | — | 2.76+ubuntu22.04.1 | Patch available | CNA |
| Canonical | Ubuntu 20.04 LTS | — | 2.67.1+20.04ubuntu1~esm2 | Patch available | CNA |
| Canonical | Ubuntu 18.04 LTS | — | 2.61.4ubuntu0.18.04.1+esm3 | Patch available | CNA |
| Canonical | Ubuntu 16.04 LTS | — | 2.61.4ubuntu0.16.04.1+esm3 | Patch available | CNA |
- snapd Vendor— Affected before 2.76.1 Fixed in 2.76.1 Patch available CNA
- Ubuntu 26.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu26.04.3 Patch available CNA
- Ubuntu 24.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu24.04.1 Patch available CNA
- Ubuntu 22.04 LTS VendorCanonical Affected — Fixed in 2.76+ubuntu22.04.1 Patch available CNA
- Ubuntu 20.04 LTS VendorCanonical Affected — Fixed in 2.67.1+20.04ubuntu1~esm2 Patch available CNA
- Ubuntu 18.04 LTS VendorCanonical Affected — Fixed in 2.61.4ubuntu0.18.04.1+esm3 Patch available CNA
- Ubuntu 16.04 LTS VendorCanonical Affected — Fixed in 2.61.4ubuntu0.16.04.1+esm3 Patch available CNA
Remediation
- Fix · CNA snapd Fixed in 2.76.1
- Fix · CNA Ubuntu 26.04 LTS (Canonical) Fixed in 2.76+ubuntu26.04.3
- Fix · CNA Ubuntu 24.04 LTS (Canonical) Fixed in 2.76+ubuntu24.04.1
- Fix · CNA Ubuntu 22.04 LTS (Canonical) Fixed in 2.76+ubuntu22.04.1
- Fix · CNA Ubuntu 20.04 LTS (Canonical) Fixed in 2.67.1+20.04ubuntu1~esm2
- Fix · CNA Ubuntu 18.04 LTS (Canonical) Fixed in 2.61.4ubuntu0.18.04.1+esm3
- Fix · CNA Ubuntu 16.04 LTS (Canonical) Fixed in 2.61.4ubuntu0.16.04.1+esm3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15226
- 2026-10-03 Alias added: GHSA-9pj8-7m3m-mh5h
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-15226 · CVE Program
- CVE-2026-15226 · NVD
- FIRST EPSS
- GHSA-9pj8-7m3m-mh5h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-15226 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences