Cross-site scripting in posimyththemes The Plus Addons for Elementor – Addons for…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Plus Addons for Elementor plugin for WordPress was vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the Button widget's `custom_attributes` setting in versions up to and including 6.4.11. The `render` function in `modules/widgets/tp_button.php` passed the raw `custom_attributes` string through `tp_senitize_js_input()`. This filter is bypassable. The issue is patched in version 6.4.12.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| posimyththemes | The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce | up to 6.4.11 | — | No fix listed | CNA |
- The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce Vendorposimyththemes Affected up to 6.4.11 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:posimyth:the_plus_addons_for_elementor:*:*:*:*:*:*:*:* | — | — | posimyththemes |
- cpe:2.3:a:posimyth:the_plus_addons_for_elementor:*:*:*:*:*:*:*:* Versions — — ·posimyththemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15285
- 2026-10-03 Alias added: GHSA-653v-fpr2-j969
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3c3217f9-67e5-488d-b80a-49a61678fb98?source=cve
- https://plugins.trac.wordpress.org/browser/the-plus-addons-for-elementor-page-builder/tags/6.4.10/modules/widgets/tp_button.php#L1549
- https://plugins.trac.wordpress.org/browser/the-plus-addons-for-elementor-page-builder/tags/6.4.11/modules/widgets/tp_button.php#L1881
- https://plugins.trac.wordpress.org/browser/the-plus-addons-for-elementor-page-builder/tags/6.4.10/modules/helper-function.php#L65
- https://plugins.trac.wordpress.org/browser/the-plus-addons-for-elementor-page-builder/tags/6.4.12/modules/widgets/tp_button.php#L1680
More posimyththemes vulnerabilities
- TI-2023-25501 WordPress The Plus Addons for Elementor Pro plugin <= 5.2.8 - Unauthenticated Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-06467 The Plus Addons for Elementor Page Builder < 4.1.7 - Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2023-24458 WordPress Nexter Theme <= 2.0.3 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2021-07228 The Plus Addons for Elementor Pro < 5.0.7 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2021-03189 Missing authorization in posimyththemes The Plus Addons for Elementor – Addons for… CVSS 3.1HIGH 8.8
- TI-2024-05069 The Plus Addons for Elementor – Elementor Addons, Page Templates, Widgets, Mega Menu… CVSS 3.1HIGH 8.8
Sources
- CVE-2026-15285 · CVE Program
- CVE-2026-15285 · NVD
- FIRST EPSS
- GHSA-653v-fpr2-j969 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences