Multiple SQL/DDL Injection and Arbitrary File Read Vulnerabilities in snowflake-sqlalchemy
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Snowflake SQLAlchemy versions prior to 1.11.0 contain several security vulnerabilities, including: Improper handling of user-supplied column identifiers in merge operations could allow SQL injection through attacker-controlled input keys. An attacker may be able to exploit this through request field names in a dynamic upsert endpoint, potentially enabling read access to data visible to the application's database role or modification of values within the same MERGE statement. Improper literal rendering of bound parameters when building certain Snowflake-specific table creation queries could allow SQL injection. An attacker may be able to exploit this by supplying a crafted string to any application endpoint that passes user-controlled data through the affected query-building API, potentially causing arbitrary data exfiltration within the scope of the connection role. Improper forwarding of connection configuration parameters could allow an attacker to cause the library to read arbitrary local files and transmit their contents to an attacker-controlled endpoint. An attacker may be able to exploit this in deployment environments that accept user-controlled connection parameters, potentially exposing sensitive files accessible to the application process. The fix is available in Snowflake SQLAlchemy version 1.11.0. Users must manually upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Snowflake | Snowflake SQLAlchemy | 1.1.6 to before 1.11.0 | 1.11.0 | Patch available | CNA |
| — | snowflake-sqlalchemy (PyPI) | 1.1.6 to before 1.11.0 | 1.11.0 | Patch available | GHSA-8g6f-qw9x-4q6q |
- Snowflake SQLAlchemy VendorSnowflake Affected 1.1.6 to before 1.11.0 Fixed in 1.11.0 Patch available CNA
- snowflake-sqlalchemy (PyPI) Vendor— Affected 1.1.6 to before 1.11.0 Fixed in 1.11.0 Patch available GHSA-8g6f-qw9x-4q6q
Remediation
- Fix · CNA Snowflake SQLAlchemy (Snowflake) Fixed in 1.11.0
- Fix · GHSA-8g6f-qw9x-4q6q snowflake-sqlalchemy (PyPI) Fixed in 1.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15736
- 2026-10-03 Alias added: GHSA-8g6f-qw9x-4q6q
References
Other 9
- Snowflake SQLAlchemy Release Notes
- https://github.com/snowflakedb/snowflake-sqlalchemy/pull/707
- https://github.com/snowflakedb/snowflake-sqlalchemy/pull/708
- https://github.com/snowflakedb/snowflake-sqlalchemy/pull/710
- https://github.com/snowflakedb/snowflake-sqlalchemy/commit/2c33792c91449e746a2c7ef24c25f0ede0a4a875
- https://github.com/snowflakedb/snowflake-sqlalchemy/commit/35edf4dc5e76b9a9fdfa74c8e4f6fd14642110f1
- https://github.com/snowflakedb/snowflake-sqlalchemy/commit/a198ed2197bb3e0be57268032ed6e8b7fdeb8129
- https://github.com/snowflakedb/snowflake-sqlalchemy
- https://github.com/snowflakedb/snowflake-sqlalchemy/releases/tag/v1.11.0
More Snowflake vulnerabilities
- TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
- TI-2026-02844 snowflakedb snowflake-jdbc JDBC URL SdkProxyRoutePlanner.java SdkProxyRoutePlanner redos CVSS 4.0MEDIUM 4.8
- TI-2026-13340 Improper TLS Hostname Verification in Snowflake Connector for Python CVSS 4.0CRITICAL 9.2
- TI-2026-09272 Streamlit Palette hashing.py weak hash CVSS 4.0LOW 2.0
- TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2023-17068 Snowflake NodeJS Driver vulnerable to Command Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2026-15736 · CVE Program
- CVE-2026-15736 · NVD
- FIRST EPSS
- GHSA-8g6f-qw9x-4q6q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences