Multiple Security Vulnerabilities in Snowflake libsnowflakeclient
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-121 and the CVSS impact.
Summary
Multiple security vulnerabilities in Snowflake libsnowflakeclient versions prior to 2.9.2 could allow remote code execution and credential exfiltration. A stack-based buffer overflow in the file download path could allow remote code execution on a victim host. An attacker could exploit this by uploading a file with a crafted encryption metadata field to a shared internal stage that a victim process later downloads, and impact would be limited to deployments where principals with different privilege levels share the same internal stage. A related out-of-bounds write in the same download path could allow memory corruption with attacker-controlled write primitives. An attacker may exploit this through a crafted initialization vector metadata field on a shared stage, and impact would be limited by the same stage-write precondition. Improper validation of connection parameters could allow an attacker-controlled input to redirect outbound authentication requests — including credentials and tokens — to an attacker-controlled endpoint. Impact is limited to embedding deployments where a lower-privileged principal can influence connection configuration while higher-privileged service credentials are in use. The fix is available in Snowflake libsnowflakeclient version 2.9.2. The Snowflake PHP PDO Driver and Snowflake ODBC Driver embed the affected library; fixes are available in versions 4.1.0 and 3.19.0 respectively. Users must manually upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Snowflake | Snowflake libsnowflakeclient | before 2.9.2 | 2.9.2 | Patch available | CNA |
| Snowflake | Snowflake PHP PDO Driver | before 4.1.0 | 4.1.0 | Patch available | CNA |
| Snowflake | Snowflake ODBC Driver | 2.16.3 to before 3.19.0 | 3.19.0 | Patch available | CNA |
- Snowflake libsnowflakeclient VendorSnowflake Affected before 2.9.2 Fixed in 2.9.2 Patch available CNA
- Snowflake PHP PDO Driver VendorSnowflake Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA
- Snowflake ODBC Driver VendorSnowflake Affected 2.16.3 to before 3.19.0 Fixed in 3.19.0 Patch available CNA
Remediation
- Fix · CNA Snowflake libsnowflakeclient (Snowflake) Fixed in 2.9.2
- Fix · CNA Snowflake PHP PDO Driver (Snowflake) Fixed in 4.1.0
- Fix · CNA Snowflake ODBC Driver (Snowflake) Fixed in 3.19.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-16870
- 2026-10-03 Alias added: GHSA-f55h-4j35-8285
References
More Snowflake vulnerabilities
- TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
- TI-2026-02844 snowflakedb snowflake-jdbc JDBC URL SdkProxyRoutePlanner.java SdkProxyRoutePlanner redos CVSS 4.0MEDIUM 4.8
- TI-2026-13340 Improper TLS Hostname Verification in Snowflake Connector for Python CVSS 4.0CRITICAL 9.2
- TI-2026-09272 Streamlit Palette hashing.py weak hash CVSS 4.0LOW 2.0
- TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2023-17068 Snowflake NodeJS Driver vulnerable to Command Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2026-16870 · CVE Program
- CVE-2026-16870 · NVD
- FIRST EPSS
- GHSA-f55h-4j35-8285 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences