Use-After-Free in MongoDB Query Execution Engine Leads to Denial of Service and Potential Memory Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
An issue in MongoDB Server's query execution engine could allow an authenticated user with read and write privileges to cause an internal reference to be used after the underlying memory has been freed, when running certain queries against time-series collections. This could result in a server crash or disclosure of freed memory contents within query results.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 8.3.0 to before 8.3.8; 8.0 to before 8.0.29 | 8.3.8, 8.0.29 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 8.3.0 to before 8.3.8; 8.0 to before 8.0.29 Fixed in 8.3.8, 8.0.29 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* | 7.0.0 – 7.0.40; 8.0.0 to before 8.0.29; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.8 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:* | 9.0.0 alpha0 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:* | 9.0.0 alpha1 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:* | 9.1.0 alpha0 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 7.0.0 – 7.0.40; 8.0.0 to before 8.0.29; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.8 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:* Versions 9.0.0 alpha0 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:* Versions 9.0.0 alpha1 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:* Versions 9.1.0 alpha0 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB) Fixed in 8.3.8, 8.0.29
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MongoDB Server 8.0.29, 8.3.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-15313 Integer underflow in MongoDB ServerPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2026-18711
- 2026-10-03 Alias added: GHSA-xv7q-6jr5-mw96
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2026-18711 · CVE Program
- CVE-2026-18711 · NVD
- FIRST EPSS
- GHSA-xv7q-6jr5-mw96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences